summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-09 16:07:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:30 +0300
commit761357ba2c861250b57e4c6b4075b069a9a08c8b (patch)
treec1716bd4f67a98b01f1fa1547bf4021164918d10
parent73858d169131797bd718f5908b51a1c675a9e226 (diff)
downloadguix-patches-761357ba2c861250b57e4c6b4075b069a9a08c8b.tar
guix-patches-761357ba2c861250b57e4c6b4075b069a9a08c8b.tar.gz
gnu: Add rust-hostname-0.3.
* gnu/packages/crates-io.scm (rust-hostname-0.3): New variable. (rust-hostname-0.1): Inherit from rust-hostname-0.3.
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 29 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d4623b1c72..2c6b013dc3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10177,30 +10177,52 @@ Hash-based Message Authentication Code}.")
("rust-md-5" ,rust-md-5-0.8)
("rust-sha2" ,rust-sha2-0.8))))))
-(define-public rust-hostname-0.1
+(define-public rust-hostname-0.3
(package
(name "rust-hostname")
- (version "0.1.5")
+ (version "0.3.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "hostname" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0kprf862qaa7lwdms6aw7f3275h0j2rwhs9nz5784pm8hdmb9ki1"))))
+ "0rz8yf70cvzl3nry71m4bz9w6x4j9kdz3qng6pnwhk2h20z1qwrw"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
- ("rust-winutil" ,rust-winutil-0.1))))
+ ("rust-match-cfg" ,rust-match-cfg-0.1)
+ ("rust-winapi" ,rust-winapi-0.3))
+ #:cargo-development-inputs
+ (("rust-version-sync" ,rust-version-sync-0.8))))
(home-page "https://github.com/svartalf/hostname")
(synopsis "Get hostname for Rust")
(description
"Get hostname for Rust.")
(license license:expat)))
+(define-public rust-hostname-0.1
+ (package
+ (inherit rust-hostname-0.3)
+ (name "rust-hostname")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hostname" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "0kprf862qaa7lwdms6aw7f3275h0j2rwhs9nz5784pm8hdmb9ki1"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-winutil" ,rust-winutil-0.1))))))
+
(define-public rust-html5ever-0.23
(package
(name "rust-html5ever")