summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 23:21:18 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:17 +0200
commit74f490ec0b1fab0d5df54a5b5b79b9f511197aa5 (patch)
tree80ddb93e0b92da076336ca51a2c7400d71151a46
parent245a2555bcdd551cc6e0fe8fde6ccffa1248f741 (diff)
downloadguix-patches-74f490ec0b1fab0d5df54a5b5b79b9f511197aa5.tar
guix-patches-74f490ec0b1fab0d5df54a5b5b79b9f511197aa5.tar.gz
gnu: ghc-zip-archive: Update to 0.3.3.
* gnu/packages/haskell.scm (ghc-zip-archive): Update to 0.3.3. [inputs]: Remove ghc-old-time and zip. [native-inputs]: Add unzip.
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b804117d84..7c5fef6c9b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2943,7 +2943,7 @@ complicated text/binary file formats.")
(define-public ghc-zip-archive
(package
(name "ghc-zip-archive")
- (version "0.3.0.5")
+ (version "0.3.3")
(source
(origin
(method url-fetch)
@@ -2953,17 +2953,16 @@ complicated text/binary file formats.")
".tar.gz"))
(sha256
(base32
- "1iwpzjck4jg9bz1yqky051i2wljsqc14q5zbi10dydfp8ip3d0yw"))))
+ "0kf8xyac168bng8a0za2jwrbss7a4ralvci9g54hnvl0gkkxx2lq"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-old-time" ,ghc-old-time)
- ("ghc-digest" ,ghc-digest)
- ("zip" ,zip)
+ `(("ghc-digest" ,ghc-digest)
("ghc-temporary" ,ghc-temporary)
("ghc-text" ,ghc-text)
("ghc-zlib" ,ghc-zlib)))
(native-inputs
- `(("ghc-hunit" ,ghc-hunit)))
+ `(("ghc-hunit" ,ghc-hunit)
+ ("unzip" ,unzip)))
(home-page "https://hackage.haskell.org/package/zip-archive")
(synopsis "Zip archive library for Haskell")
(description "The zip-archive library provides functions for creating,