summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-28 17:26:07 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 17:01:33 +0200
commit71a03c29bf2c4913b5591f3affdde65a75f54537 (patch)
tree95b84b7d601619e18e16ebe730180ff4e773aff6
parentad79eb554d626e5546605d3ad0bccc25d65320f8 (diff)
downloadguix-patches-71a03c29bf2c4913b5591f3affdde65a75f54537.tar
guix-patches-71a03c29bf2c4913b5591f3affdde65a75f54537.tar.gz
gnu: Add ruby-atoulme-antwrap.
* gnu/packages/ruby.scm (ruby-atoulme-antwrap): New variable.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 84bfb82e76..aaea81516e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -419,6 +419,30 @@ Java Native Interface.")
(home-page "http://www.artonx.org/collabo/backyard/?RubyJavaBridge")
(license license:lgpl2.1+)))
+(define-public ruby-atoulme-antwrap
+ (package
+ (name "ruby-atoulme-antwrap")
+ (version "0.7.5")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "atoulme-Antwrap" version))
+ (sha256
+ (base32
+ "05s3iw44lqa81f8nfy5f0xjj808600h82zb9bsh46b9kcq2w2kmz"))))
+ (build-system ruby-build-system)
+ ;; Test data required for most of the tests are not included.
+ (arguments `(#:tests? #f))
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (inputs
+ `(("ruby-rjb" ,ruby-rjb)))
+ (synopsis "Ruby wrapper for the Ant build tool")
+ (description "Antwrap is a Ruby module that wraps the Apache Ant build
+tool. Antwrap can be used to invoke Ant tasks from a Ruby or a JRuby
+script.")
+ (home-page "http://rubyforge.org/projects/antwrap/")
+ (license license:expat)))
+
(define-public ruby-useragent
(package
(name "ruby-useragent")