summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-18 12:50:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-19 21:56:56 -0500
commit7196b8c5ea0194b3c67513bf9916c7b1a85118b5 (patch)
treeffb7a540b86e0bdf1c646b6df480e47c17846559
parent14641312a90e036b0be2d57b3a358578fc46540a (diff)
downloadguix-patches-7196b8c5ea0194b3c67513bf9916c7b1a85118b5.tar
guix-patches-7196b8c5ea0194b3c67513bf9916c7b1a85118b5.tar.gz
gnu: python-ddt: Update to 1.4.1.
* gnu/packages/python-xyz.scm (python-ddt): Update to 1.4.1. [native-inputs]: Remove python-mock, python-nose. [propagated-inputs]: Remove python-six. [home-page]: Update. (python2-ddt): Remove variable.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c011020a4c..b9c20ca415 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14708,22 +14708,20 @@ converting text with ANSI color codes to HTML or LaTeX.")
(define-public python-ddt
(package
(name "python-ddt")
- (version "1.1.3")
+ (version "1.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ddt" version))
(sha256
(base32
- "1lw17420iimhghkgzgax85nn8d1an2d6k2cfvb7j5kwn2dqlr1vk"))))
+ "1niqpzc26sxdbyi46r07n4pma5fjx6crww2539vpfmsf0w6yg585"))))
(build-system python-build-system)
(native-inputs
- `(("python-mock" ,python-mock)
- ("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)))
(propagated-inputs
- `(("python-six" ,python-six)
- ("python-pyyaml" ,python-pyyaml)))
- (home-page "https://github.com/txels/ddt")
+ `(("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/datadriventests/ddt")
(synopsis "Data-Driven Tests")
(description
"Data-Driven Tests (@dfn{DDT}) allow you to multiply one test case by
@@ -14731,9 +14729,6 @@ running it with different test data, and make it appear as multiple test
cases.")
(license license:expat)))
-(define-public python2-ddt
- (package-with-python2 python-ddt))
-
(define-public python-pycountry
(package
(name "python-pycountry")