summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-06 11:46:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-07 14:08:30 +0200
commit70dcd7c78bdbe8bacf1b130090be0c788547689e (patch)
tree75e9f35a586e2f2860c2089f38933f5355059f12
parent6667576b66b34d797c4b5ca4a9ef08ba921b5d2a (diff)
downloadguix-patches-70dcd7c78bdbe8bacf1b130090be0c788547689e.tar
guix-patches-70dcd7c78bdbe8bacf1b130090be0c788547689e.tar.gz
gnu: Add emacs-chess.
* gnu/packages/emacs-xyz.scm (emacs-chess): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8ca331efd5..b1b9bf4a29 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5905,6 +5905,37 @@ The goal of this game is to create a tile with value 2048. The size of the
board and goal value can be customized.")
(license license:gpl3+)))
+(define-public emacs-chess
+ (package
+ (name "emacs-chess")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "chess-" version ".tar"))
+ (sha256
+ (base32 "1sq1bjmp513vldfh7hc2bbfc54665abqiz0kqgqq3gijckaxn5js"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-pieces
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (pieces
+ (string-append out "/share/emacs/site-lisp/pieces")))
+ (mkdir-p site-lisp)
+ (copy-recursively "pieces" pieces)
+ #t))))))
+ (home-page "https://elpa.gnu.org/packages/chess.html")
+ (synopsis "Play chess in GNU Emacs")
+ (description
+ "Chess is an Emacs Lisp library and several clients on top of the
+underlying library functionality for performing various activities related to
+the game of chess.")
+ (license license:gpl3+)))
+
(define-public emacs-4clojure
;; There is no release. Base version is extracted from Version keyword in
;; the main file.