summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-16 10:58:31 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-16 10:58:31 +0200
commit7051054a0a2751af840159e3aa68ffd0cdb5cb84 (patch)
tree682de2a56451117082fd804e40b328e586bf0db2
parent8a79ec41e8bec04af4f889a4fdf2b25e3641f12c (diff)
downloadguix-patches-7051054a0a2751af840159e3aa68ffd0cdb5cb84.tar
guix-patches-7051054a0a2751af840159e3aa68ffd0cdb5cb84.tar.gz
gnu: clucene: Add patch to indicate linking with clucene-shared, not only
clucene-core, to pkgconfig. * gnu/packages/patches/clucene-pkgconfig.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch. * gnu/packages/rdf.scm (clucene): Use patch.
-rw-r--r--gnu-system.am3
-rw-r--r--gnu/packages/patches/clucene-pkgconfig.patch21
-rw-r--r--gnu/packages/rdf.scm4
3 files changed, 26 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 93841e227a..86bdb6986e 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -1,6 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-# Copyright © 2013 Andreas Enge <andreas@enge.fr>
+# Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
# Copyright © 2013, 2014 Mark H Weaver <mhw@netris.org>
#
# This file is part of GNU Guix.
@@ -261,6 +261,7 @@ dist_patch_DATA = \
gnu/packages/patches/bitlbee-fix-tests.patch \
gnu/packages/patches/bitlbee-memset-fix.patch \
gnu/packages/patches/cdparanoia-fpic.patch \
+ gnu/packages/patches/clucene-pkgconfig.patch \
gnu/packages/patches/cmake-fix-tests.patch \
gnu/packages/patches/coreutils-dummy-man.patch \
gnu/packages/patches/coreutils-skip-nohup.patch \
diff --git a/gnu/packages/patches/clucene-pkgconfig.patch b/gnu/packages/patches/clucene-pkgconfig.patch
new file mode 100644
index 0000000000..5e4825cd3f
--- /dev/null
+++ b/gnu/packages/patches/clucene-pkgconfig.patch
@@ -0,0 +1,21 @@
+Taken from the Debian package.
+
+From 7be4a19b76d98260cf95040a47935f854a4ba7a4 Mon Sep 17 00:00:00 2001
+From: Valentin Rusu <kde@rusu.info>
+Date: Sat, 17 Dec 2011 13:47:58 +0100
+Subject: [PATCH] Fix .pc file by adding clucene-shared library
+
+---
+ src/core/libclucene-core.pc.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/core/libclucene-core.pc.cmake
++++ b/src/core/libclucene-core.pc.cmake
+@@ -6,6 +6,6 @@ includedir=${prefix}/include:${prefix}/i
+ Name: libclucene
+ Description: CLucene - a C++ search engine, ported from the popular Apache Lucene
+ Version: @CLUCENE_VERSION_MAJOR@.@CLUCENE_VERSION_MINOR@.@CLUCENE_VERSION_REVISION@.@CLUCENE_VERSION_PATCH@
+-Libs: -L${prefix}/@LIB_DESTINATION@/ -lclucene-core
++Libs: -L${prefix}/@LIB_DESTINATION@/ -lclucene-core -lclucene-shared
+ Cflags: -I${prefix}/include -I${prefix}/include/CLucene/ext
+ ~
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index c9364de6f1..dec2f0e3ee 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -22,6 +22,7 @@
#:use-module (guix download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -72,7 +73,8 @@ HTML and JSON.")
version ".tar.gz"))
(sha256
(base32
- "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))))
+ "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))
+ (patches (list (search-patch "clucene-pkgconfig.patch")))))
(build-system cmake-build-system)
(inputs
`(("boost" ,boost) ; could also use bundled copy