summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-22 19:00:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-23 14:01:31 +0100
commit6d5c54cbee0300bc19b8219681429726909825c1 (patch)
tree0370a9b5353257c1276c9cf6f5096fee062ffe56
parent084600e3ca938c1bb806bc2152bb5182b831b647 (diff)
downloadguix-patches-6d5c54cbee0300bc19b8219681429726909825c1.tar
guix-patches-6d5c54cbee0300bc19b8219681429726909825c1.tar.gz
gnu: Add r-admisc.
* gnu/packages/cran.scm (r-admisc): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2ac787dbcf..703018d484 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12784,6 +12784,31 @@ Anderson-Darling Distribution\".")
;; Any version of the GPL.
(license license:gpl3+)))
+(define-public r-admisc
+ (package
+ (name "r-admisc")
+ (version "0.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "admisc" version))
+ (sha256
+ (base32 "1jwz9z3brq4lbnqrkxx40vrn47rknkkj4xfv2gi8kmf1mzc5aqcd"))))
+ (properties `((upstream-name . "admisc")))
+ (build-system r-build-system)
+ (home-page "https://github.com/dusadrian/admisc")
+ (synopsis "Adrian Dusa's miscellaneous")
+ (description
+ "This package contains miscellaneous functions used to interpret and
+translate, factorize and negate Sum of Products expressions, for both binary
+and multi-value crisp sets, and to extract information (set names, set values)
+from those expressions. Other functions perform various other checks if
+possibly numeric (even if all numbers reside in a character vector) and coerce
+to numeric, or check if the numbers are whole. It also offers, among many
+others, a highly flexible recoding routine and a more flexible alternative to
+the base function @code{with()}.")
+ (license license:gpl3+)))
+
(define-public r-sodium
(package
(name "r-sodium")