summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-03-18 20:59:49 -0500
committerGuix Patches Tester <>2020-04-19 20:26:10 +0100
commit6bea3b9fe1dcaadec816cb16b1c4995da209b406 (patch)
tree33eb8d998ae0bd9133a05d6b7d5de2e7938d2059
parent58d5b8b44b37b1f9df279ed02a3c11f580caa634 (diff)
downloadguix-patches-6bea3b9fe1dcaadec816cb16b1c4995da209b406.tar
guix-patches-6bea3b9fe1dcaadec816cb16b1c4995da209b406.tar.gz
gnu: Add emacs-pretty-hydra.
* gnu/packages/emacs-xyz.scm (emacs-pretty-hydra): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cd80e57efb..4588bd1633 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5842,6 +5842,34 @@ the Hydra very seamless; it's like a minor mode that disables itself
automatically.")
(license license:gpl3+)))
+(define-public emacs-pretty-hydra
+ (package
+ (name "emacs-pretty-hydra")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jerrypnz/major-mode-hydra.el.git")
+ (commit version)))
+ (sha256
+ (base32
+ "08a15knkdq35pzjq82imff016fbfdib5q4glg2xmdy2b5fnk7jqa"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-hydra" ,emacs-hydra)
+ ("emacs-s" ,emacs-s)))
+ (arguments
+ `(#:exclude (cons "^major-mode-hydra\\.el" %default-exclude)))
+ (home-page "https://github.com/jerrypnz/major-mode-hydra.el")
+ (synopsis "Major mode keybindings managed by Hydra")
+ (description
+ "This package offers an hydra-based method of managing major
+mode-specific key bindings. It is intended for use as a library only; see
+package @code{emacs-major-mode-hydra} for a user-friendly interface.")
+ (license license:gpl3+)))
+
(define-public emacs-ivy
(package
(name "emacs-ivy")