summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-03 16:24:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-03 17:42:18 +0200
commit6b12f213633e035e8b6eb61c36cfdbd19b434754 (patch)
treec006d87d9e701c68a0601ab2ed62422b241e2d71
parent7b5101c5bf9fb33768ae90e0e32ba2f67a491bc3 (diff)
downloadguix-patches-6b12f213633e035e8b6eb61c36cfdbd19b434754.tar
guix-patches-6b12f213633e035e8b6eb61c36cfdbd19b434754.tar.gz
gnu: Add r-webbioc.
* gnu/packages/bioconductor.scm (r-webbioc): New variable.
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 61ea05a7a7..7928a10679 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -32,6 +32,8 @@
#:use-module (gnu packages haskell)
#:use-module (gnu packages image)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages netpbm)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages statistics)
#:use-module (gnu packages web))
@@ -4117,3 +4119,36 @@ visualization of exonic read coverage.")
widgets in R.")
;; Any version of the LGPL.
(license license:lgpl3+)))
+
+(define-public r-webbioc
+ (package
+ (name "r-webbioc")
+ (version "1.54.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "webbioc" version))
+ (sha256
+ (base32
+ "16n6wc9q51wfpmh9y77p53sqdqdd8pn50c67vf6h4n7gv5wgnpwi"))))
+ (build-system r-build-system)
+ (inputs
+ `(("netpbm" ,netpbm)
+ ("perl" ,perl)))
+ (propagated-inputs
+ `(("r-affy" ,r-affy)
+ ("r-annaffy" ,r-annaffy)
+ ("r-biobase" ,r-biobase)
+ ("r-biocmanager" ,r-biocmanager)
+ ("r-gcrma" ,r-gcrma)
+ ("r-multtest" ,r-multtest)
+ ("r-qvalue" ,r-qvalue)
+ ("r-vsn" ,r-vsn)))
+ (home-page "https://www.bioconductor.org/")
+ (synopsis "Bioconductor web interface")
+ (description
+ "This package provides an integrated web interface for doing microarray
+analysis using several of the Bioconductor packages. It is intended to be
+deployed as a centralized bioinformatics resource for use by many users.
+Currently only Affymetrix oligonucleotide analysis is supported.")
+ (license license:gpl2+)))