summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen J Woodcroft <donttrustben@gmail.com>2016-09-26 15:26:17 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-09-27 20:07:02 +1000
commit67f66812f5ef1bfba59cfd53ace6f41196cd0227 (patch)
tree662b29b2f86c1ad83c6c6122bf2898d7902d1ab8
parentf536dce522e08315c468f60448507af2cac619ac (diff)
downloadguix-patches-67f66812f5ef1bfba59cfd53ace6f41196cd0227.tar
guix-patches-67f66812f5ef1bfba59cfd53ace6f41196cd0227.tar.gz
gnu: Add python-termcolor.
* gnu/packages/python.scm (python-termcolor, python2-termcolor): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 688a5d4ee8..529b7fdb09 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6295,6 +6295,30 @@ a hash value.")
(name "python2-tlsh")
(inputs `(("python" ,python-2)))))
+(define-public python-termcolor
+ (package
+ (name "python-termcolor")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-termcolor" version))
+ (sha256
+ (base32
+ "0fv1vq14rpqwgazxg4981904lfyp84mnammw7y046491cv76jv8x"))))
+ (build-system python-build-system)
+ (arguments
+ ;; There are no tests.
+ `(#:tests? #f))
+ (home-page "http://pypi.python.org/pypi/termcolor")
+ (synopsis "ANSII Color formatting for terminal output")
+ (description
+ "This package provides ANSII Color formatting for output in terminals.")
+ (license license:expat)))
+
+(define-public python2-termcolor
+ (package-with-python2 python-termcolor))
+
(define-public python-libarchive-c
(package
(name "python-libarchive-c")