summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-07 13:52:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-07 13:52:28 +0200
commit675bca979e30314cdaed31656887ad52460f14e2 (patch)
treebcc89e052efb27feb1ac3898885b8786767a0fd8
parent4f9db5693e79db9e1d6c41c10ae1678ca27b2be3 (diff)
downloadguix-patches-675bca979e30314cdaed31656887ad52460f14e2.tar
guix-patches-675bca979e30314cdaed31656887ad52460f14e2.tar.gz
gnu: Add plover.
* gnu/local.mk (plover): New variable. (GNU_SYSTEM_MODULES): Add stenography.scm.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/stenography.scm65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9a691525a2..a277e63fa4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -505,6 +505,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/stalonetray.scm \
%D%/packages/statistics.scm \
%D%/packages/stb.scm \
+ %D%/packages/stenography.scm \
%D%/packages/storage.scm \
%D%/packages/suckless.scm \
%D%/packages/swig.scm \
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
new file mode 100644
index 0000000000..f0193da25f
--- /dev/null
+++ b/gnu/packages/stenography.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages stenography)
+ #:use-module (guix build-system python)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages libusb)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages wxwidgets))
+
+(define-public plover
+ (package
+ (name "plover")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openstenoproject/plover.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "114rlxvq471fyifwcdcgdad79ak7q3w2lk8z9nqhz1i9fg05721c"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("python2-mock" ,python2-mock)
+ ("python2-pytest" ,python2-pytest)
+ ("python2-setuptools-scm" ,python2-setuptools-scm)))
+ (inputs
+ `(("python2-appdirs" ,python2-appdirs)
+ ("python2-dbus" ,python2-dbus)
+ ("python2-hidapi" ,python2-hidapi)
+ ("python2-pyserial" ,python2-pyserial)
+ ("python2-wxpython" ,python2-wxpython)
+ ("python2-xlib" ,python2-xlib)))
+ (home-page "https://www.openstenoproject.org/plover/")
+ (synopsis "Stenography engine")
+ (description
+ "Plover (rhymes with @emph{lover}) is a desktop application that
+allows anyone to use stenography to write on their computer, up to
+speeds of 200WPM and beyond.")
+ (license license:gpl2+)))
+