summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-03-04 13:01:19 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-11 23:34:50 -0500
commit662f1f7bbac54d5762a06862b6174977003f46b9 (patch)
treeeea6e1ac9501f3e4fcf5ba8002dd48e342ee4e4c
parentfbc46b61daca05f8f8082fc90a62a5708415d651 (diff)
downloadguix-patches-662f1f7bbac54d5762a06862b6174977003f46b9.tar
guix-patches-662f1f7bbac54d5762a06862b6174977003f46b9.tar.gz
gnu: ghc-bsb-http-chunked: Don't run tests when cross-compiling.base-for-series-11600base-for-series-11597base-for-series-11595
* gnu/packages/haskell-web.scm (ghc-bsb-http-chunked)[arguments]<#:tests?>: Set to #false when cross-compiling. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/haskell-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 34dd2556be..70a4eccce6 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -603,8 +603,9 @@ Haskell's Web Application Interface (WAI).")
(arguments
`(;; XXX: As of 0.0.4, one property test ("Identical output as Blaze")
;; fails on i686-linux.
- #:tests? ,(not (string-prefix? "i686" (or (%current-target-system)
- (%current-system))))
+ #:tests? ,(and (not (%current-target-system))
+ (not (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))))
#:cabal-revision
("3" "15hg352id2f4x0dnvv47bdiz6gv5hp5a2mki9yzmhc7ajpk31mdd")))
(native-inputs