summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 20:13:48 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:20 +0300
commit6540696d6e6479bcb5d3e9eb91a2f5442dd9679d (patch)
treef7b9fe13ee191d25335d2e67a620b52255b17a43
parent6f13177a6ec4f407bbf0ad30c5804a9af862ba89 (diff)
downloadguix-patches-6540696d6e6479bcb5d3e9eb91a2f5442dd9679d.tar
guix-patches-6540696d6e6479bcb5d3e9eb91a2f5442dd9679d.tar.gz
gnu: Add rust-rustc-ap-rustc-arena-654.
* gnu/packages/crates-io.scm (rust-rustc-ap-rustc-arena-654): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ee625f3b1a..d8bf776d8f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20201,6 +20201,35 @@ password hashing function.")
"This package provides a sys crate for the rust_hawktracer library.")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-ap-arena-654
+ (package
+ (name "rust-rustc-ap-arena")
+ (version "654.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-ap-arena" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18yc4i5m2vf6w8na29i5jv8l4l0yknsf6xn0z2mk7mfz1nxwzpw1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-rustc-ap-rustc-data-structures"
+ ,rust-rustc-ap-rustc-data-structures-654)
+ ("rust-smallvec" ,rust-smallvec-1))))
+ (home-page "https://github.com/alexcrichton/rustc-auto-publish")
+ (synopsis
+ "Automatically published version of the arena package used in rustc")
+ (description
+ "Use the arena library used in the Rust compiler with this crate.
+It is automatically published using the compiler repository at
+@url{https://www.github.com/rust-lang/rust}")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustc-demangle-0.1
(package
(name "rust-rustc-demangle")