summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-04-29 14:36:37 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-29 14:36:37 +0200
commit653eef9b41ad74cb0e0aa10ed4ca691359b2515a (patch)
treeb42873e2b5dc0fbca5e2a5937851f26c36b4c573
parent03f660027cb8abcdec0bd5acf466b3956cc2752c (diff)
downloadguix-patches-653eef9b41ad74cb0e0aa10ed4ca691359b2515a.tar
guix-patches-653eef9b41ad74cb0e0aa10ed4ca691359b2515a.tar.gz
gnu: Add urh.
* gnu/packages/radio.scm (urh): New variable. Co-authored-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/radio.scm64
1 files changed, 63 insertions, 1 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index aa0406b324..88bc36bfde 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2019, 2020, 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
@@ -2424,6 +2424,68 @@ vendor-neutral SDR support library instead, intended to support a wider range
of devices than RTL-SDR.")
(license license:gpl2+))))
+(define-public urh
+ (package
+ (name "urh")
+ (version "2.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jopohl/urh")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17r9fkw0icph7fayibp6qbdh4nxi8wy3mmd3djmh0c2jr8yz5fsf"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-cython
+ python-pytest
+ xorg-server-for-tests))
+ (inputs
+ (list gnuradio
+ gr-osmosdr
+ hackrf
+ python-numpy
+ python-psutil
+ python-pyaudio
+ python-pyqt
+ rtl-sdr))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure-compiler
+ (lambda _
+ ;; Use gcc as compiler
+ (substitute* "src/urh/dev/native/ExtensionHelper.py"
+ (("compiler = ccompiler\\.new_compiler\\(\\)\n" all)
+ (string-append
+ all " compiler.set_executables(compiler='gcc',"
+ " compiler_so='gcc', linker_exe='gcc', linker_so='gcc -shared')\n")))))
+ (add-after 'unpack 'disable-some-tests
+ (lambda _
+ (for-each delete-file
+ '(;; FIXME: This test causes a segmentation fault
+ "tests/test_send_recv_dialog_gui.py"))))
+ (add-after 'build 'build-cythonext
+ (lambda _
+ (invoke "python" "src/urh/cythonext/build.py")))
+ (replace 'check
+ (lambda* (#:key inputs tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (system (string-append (search-input-file inputs "/bin/Xvfb")
+ " :1 &"))
+ (setenv "DISPLAY" ":1")
+ (invoke "pytest")))))))
+ (home-page "https://github.com/jopohl/urh")
+ (synopsis "Wireless protocol investigation program")
+ (description
+ "The Universal Radio Hacker (URH) is a complete suite for wireless
+protocol investigation with native support for many common Software Defined
+Radios.")
+ (license license:gpl3+)))
+
(define-public gnss-sdr
(package
(name "gnss-sdr")