summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-04 09:50:22 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-04 22:49:34 +0100
commit61bdd0d89f1e8851df890ce1f09c6969e2ee16fd (patch)
tree43b8aee5ee4989a5b1dc87c3974d99b0582a1712
parent3b9855f496de70de0acc99f60a679caecea4bac7 (diff)
downloadguix-patches-61bdd0d89f1e8851df890ce1f09c6969e2ee16fd.tar
guix-patches-61bdd0d89f1e8851df890ce1f09c6969e2ee16fd.tar.gz
gnu: wpa-supplicant: Use GnuTLS instead of OpenSSL.
* gnu/packages/admin.scm (wpa-supplicant)[arguments] <configure phase>: Set CONFIG_TLS. [inputs]: Add GNUTLS and LIBGCRYPT.
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index cadd3c4766..aa1f8d1b9a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
@@ -38,6 +38,8 @@
#:use-module (gnu packages tcl)
#:use-module ((gnu packages compression) #:prefix c:)
#:use-module ((gnu packages openssl) #:prefix o:)
+ #:use-module (gnu packages gnutls)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages glib)
@@ -699,6 +701,9 @@ commands and their arguments.")
(display "
CONFIG_DEBUG_SYSLOG=y
+ # Choose GnuTLS (the default is OpenSSL.)
+ CONFIG_TLS=gnutls
+
# TODO: Add a variant of this package with DBus support.
#CONFIG_CTRL_IFACE_DBUS=y
#CONFIG_CTRL_IFACE_DBUS_NEW=y
@@ -723,7 +728,8 @@ commands and their arguments.")
;; TODO: Add a variant with DBus support. This significantly increases
;; the size of its closure since DBus depends on libx11.
;; ("dbus" ,dbus)
- ("openssl" ,o:openssl)))
+ ("gnutls" ,gnutls)
+ ("libgcrypt" ,libgcrypt))) ;needed by crypto_gnutls.c
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://w1.fi/wpa_supplicant/")