summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-07 00:05:39 +0100
committerGuix Patches Tester <>2020-03-06 23:15:10 +0000
commit618f31df1f675ad0e447c33d182f160cf5d13777 (patch)
tree4da9ab5e5587088fea8de236a9478c21cc39dc8e
parent895e6e8af657d28527f7cccf68eab7319f50fba5 (diff)
downloadguix-patches-618f31df1f675ad0e447c33d182f160cf5d13777.tar
guix-patches-618f31df1f675ad0e447c33d182f160cf5d13777.tar.gz
gnu: Add traceroute.
* gnu/packages/networking.scm (traceroute): New variable.
-rw-r--r--gnu/packages/networking.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index eddfffd662..92b6391a53 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2864,6 +2864,51 @@ Such interfaces are useful for VPN software, virtualization, emulation,
simulation, and a number of other applications.")
(license license:gpl2)))
+(define-public traceroute
+ (package
+ (name "traceroute")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/traceroute/traceroute/"
+ "traceroute-" version "/traceroute-" version ".tar.gz"))
+ (sha256
+ (base32 "1dh32vcfawkl1p9g4ral1p0camds4paqr8db1kaqxwyk6hmd4s9n"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-make
+ (lambda _
+ (substitute* "Make.rules"
+ ((" -lm ") " "))
+ #t))
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((libglibc (assoc-ref inputs "glibc"))
+ (headers (assoc-ref inputs "linux-libre-headers")))
+ (invoke "make" "LDFLAGS=-lm -L../libsupp"
+ (string-append "LIBRARY_PATH=" libglibc "/lib")
+ (string-append "CFLAGS=-I" headers "/include")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make" (string-append "prefix=" out) "install"))))
+ (delete 'bootstrap) ;there is no configure.ac file
+ (delete 'configure)))) ;there is no configure script
+ (native-inputs
+ `(("glibc" ,glibc)
+ ("linux-libre-headers" ,linux-libre-headers)))
+ (home-page "http://traceroute.sourceforge.net/")
+ (synopsis "Tracks the route taken by packets over an IP network")
+ (description "Traceroute tracks the route packets taken from an IP network
+on their way to a given host. It utilizes the IP protocol's time to live (TTL)
+field and attempts to elicit an ICMP TIME_EXCEEDED response from each gateway
+along the path to the host.")
+ (license license:gpl2)))
+
(define-public vde2
(package
(name "vde2")