summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-07 16:48:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-11 15:39:29 +0200
commit6145e25afa597a1c3c571df8d1ec0ca69b69125f (patch)
tree9de836cae76669319a84510227f8f047081e98cb
parent8499f14a215a7ba020e8e87292e66de631027b08 (diff)
downloadguix-patches-6145e25afa597a1c3c571df8d1ec0ca69b69125f.tar
guix-patches-6145e25afa597a1c3c571df8d1ec0ca69b69125f.tar.gz
gnu: Add python-yte.
* gnu/packages/python-xyz.scm (python-yte): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12a79d8450..12f0779ba6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9938,6 +9938,29 @@ multiprecision arithmetic.")
function signatures.")
(license license:bsd-3)))
+(define-public python-yte
+ (package
+ (name "python-yte")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "yte" version))
+ (sha256
+ (base32 "07hm1warpqi4ifqgkaz5sg887x4a44yhxafmpf835ywnpchg4s03"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list python-plac python-pyyaml))
+ (home-page "https://github.com/koesterlab/yte")
+ (synopsis "YAML template engine with Python expressions")
+ (description
+ "This package provides a YAML template engine with Python expressions.")
+ (license license:expat)))
+
(define-public python-sympy
(package
(name "python-sympy")