summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-27 10:00:49 +0200
committerMarius Bakke <marius@gnu.org>2020-07-30 00:57:28 +0200
commit5eebb4f41b00b1092e817046c1b1a665f298aa4b (patch)
tree88aeee7e154e6d84d7f8d625b4746475841dc56c
parentfdc61e32601776045eb51ac9d86e38a53adb0b7e (diff)
downloadguix-patches-5eebb4f41b00b1092e817046c1b1a665f298aa4b.tar
guix-patches-5eebb4f41b00b1092e817046c1b1a665f298aa4b.tar.gz
gnu: Add python-flake8-bugbear.
* gnu/packages/python-xyz.scm (python-flake8-bugbear): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b54b6538dc..65541994fe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7910,6 +7910,42 @@ complexity of Python source code.")
("python-pyflakes" ,python-pyflakes-1.2)
("python-mccabe" ,python-mccabe)))))
+(define-public python-flake8-bugbear
+ (package
+ (name "python-flake8-bugbear")
+ (version "20.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-bugbear" version))
+ (sha256
+ (base32
+ "0qiihb242fygzyrfynq913ak7cdmx8mcac9c0zk3y5gv16qf80mx"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-test
+ (lambda _
+ ;; This test fails on slow computers.
+ (substitute* "tests/test_bugbear.py"
+ (("def test_does_not_crash_on_any_valid_code")
+ "def _test_does_not_crash_on_any_valid_code")))))))
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-hypothesmith" ,python-hypothesmith)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-flake8" ,python-flake8)))
+ (home-page "https://github.com/PyCQA/flake8-bugbear")
+ (synopsis
+ "Flake8 plugin for finding likely bugs and design problems in your program")
+ (description
+ "This package contains a plugin for Flake8 finding likely bugs and
+design problems in your program. It contains warnings that don't belong
+in pyflakes and pycodestyle.")
+ (license license:expat)))
+
(define-public python-flake8-polyfill
(package
(name "python-flake8-polyfill")