summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-13 02:17:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-13 02:26:21 +0200
commit5cc5364ebad7f72afe0213b0a58997c195722a0a (patch)
treed0510dcd4c9a817ae57e7215781edeccc6153bf0
parent76533c52c06de4823738b32e450a1a06522018d1 (diff)
downloadguix-patches-5cc5364ebad7f72afe0213b0a58997c195722a0a.tar
guix-patches-5cc5364ebad7f72afe0213b0a58997c195722a0a.tar.gz
gnu: dstat: Add python2-six.
* gnu/packages/admin.scm (dstat)[inputs]: Add python2-six. [arguments]: Add ‘wrap’ phase to make dstat find required modules.
-rw-r--r--gnu/packages/admin.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d85bd6e324..9392c59521 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2140,9 +2140,20 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list (string-append "DESTDIR=" out)
"prefix=/"))
- ;; No configure script.
- #:phases (modify-phases %standard-phases (delete 'configure))))
- (inputs `(("python-2" ,python-2)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/dstat")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
+ #t))))))
+ (inputs
+ ;; Python 3 is supposedly supported but prints a DeprecationWarning.
+ ;; Upstream is dead. See <https://github.com/dagwieers/dstat/releases>.
+ `(("python" ,python-wrapper)
+ ("python-six" ,python-six)))
(synopsis "Versatile resource statistics tool")
(description "Dstat is a versatile replacement for @command{vmstat},
@command{iostat}, @command{netstat}, and @command{ifstat}. Dstat overcomes