summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:25:17 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit5bf3afea6867627be0aab25cb2eb6aad11f1620c (patch)
treeaafba116fdd463ab3a358f5bb62671133c5f882c
parentd8fa80e13fbe7295dd85dffd89e15bbf748f5143 (diff)
downloadguix-patches-5bf3afea6867627be0aab25cb2eb6aad11f1620c.tar
guix-patches-5bf3afea6867627be0aab25cb2eb6aad11f1620c.tar.gz
gnu: Add python-testscenarios.
* gnu/packages/python.scm (python-testscenarios, python2-testscenarios): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b02f91e464..61127d8ae0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1184,6 +1184,34 @@ compatibility.")
(define-public python2-testtools
(package-with-python2 python-testtools))
+(define-public python-testscenarios
+ (package
+ (name "python-testscenarios")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/t/testscenarios/testscenarios-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1671jvrvqlmbnc42j7pc5y6vc37q44aiwrq0zic652pxyy2fxvjg"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-testtools" ,python-testtools)
+ ("python-mimeparse" ,python-mimeparse)))
+ (home-page "https://launchpad.net/testscenarios")
+ (synopsis "Pyunit extension for dependency injection")
+ (description
+ "Testscenarios provides clean dependency injection for Python unittest
+style tests.")
+ (license (list bsd-3 asl2.0)))) ; at the user's option
+
+(define-public python2-testscenarios
+ (package-with-python2 python-testscenarios))
+
(define-public behave
(package
(name "behave")