summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-05 10:39:16 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-07-05 11:33:56 +0200
commit5b87bacd548dc3e18218d5dc8c6e4101091b86ea (patch)
tree06c9f52164931c80557f4058d0edfdd4af6948c0
parentf96c3bbe24557b1969fb4979a61ddf3b2c9caf06 (diff)
downloadguix-patches-5b87bacd548dc3e18218d5dc8c6e4101091b86ea.tar
guix-patches-5b87bacd548dc3e18218d5dc8c6e4101091b86ea.tar.gz
gnu: chessx: Update to 1.5.4.
* gnu/packages/games.scm (chessx): Update to 1.5.4, [inputs]: add "qtspeech", [arguments]: fix missing translations. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/games.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c062729f89..14dea16543 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11294,20 +11294,21 @@ and chess engines.")
(define-public chessx
(package
(name "chessx")
- (version "1.5.0")
+ (version "1.5.4")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/chessx/chessx/"
version "/chessx-" version ".tgz"))
(sha256
- (base32 "09rqyra28w3z9ldw8sx07k5ap3sjlli848p737maj7c240rasc6i"))))
+ (base32 "1a3541vl5hp6jllgx998w9kjh9kp3wrl80yfwkxmq1bc5bzsrnz2"))))
(build-system qt-build-system)
(native-inputs
`(("qttools" ,qttools)))
(inputs
`(("qtbase" ,qtbase)
("qtmultimedia" ,qtmultimedia)
+ ("qtspeech" ,qtspeech)
("qtsvg" ,qtsvg)
("zlib" ,zlib)))
(arguments
@@ -11318,7 +11319,12 @@ and chess engines.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "chessx.pro"
(("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
- (string-append (assoc-ref inputs "qttools") "/bin/lrelease")))
+ (string-append (assoc-ref inputs "qttools") "/bin/lrelease"))
+ ;; Fix missing translations.
+ (("TRANSLATIONS = i18n/chessx_de.ts")
+ "TRANSLATIONS = i18n/chessx_de.ts i18n/chessx_da.ts \\
+i18n/chessx_fr.ts i18n/chessx_it.ts i18n/chessx_cz.ts i18n/chessx_ru.ts \\
+i18n/chessx_es.ts"))
#t))
(add-after 'fix-paths 'make-qt-deterministic
(lambda _