summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-06 16:52:40 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-08-08 09:30:44 +1000
commit5b0c223ae3470d8f9433d6301eeb9eeaf9193b90 (patch)
treebf869051cb01bd66ed679c6ce8173f7d03ba41f7
parent5071f17b29ab40c44c329668550b85bc606cee02 (diff)
downloadguix-patches-5b0c223ae3470d8f9433d6301eeb9eeaf9193b90.tar
guix-patches-5b0c223ae3470d8f9433d6301eeb9eeaf9193b90.tar.gz
gnu: ruby-nokogiri-diff: Update to 0.2.0-1.a38491e4.
* gnu/packages/ruby.scm (ruby-nokogiri-diff): Update to 0.2.0-1.a38491e4.
-rw-r--r--gnu/packages/ruby.scm49
1 files changed, 27 insertions, 22 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4c8a6f2e5c..29677dc025 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2905,29 +2905,34 @@ tree-like structures. It is similar to Ruby's built-in @code{TSort} module.")
(license license:expat))))
(define-public ruby-nokogiri-diff
- (package
- (name "ruby-nokogiri-diff")
- (version "0.2.0")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "nokogiri-diff" version))
- (sha256
- (base32
- "0njr1s42war0bj1axb2psjvk49l74a8wzr799wckqqdcb6n51lc1"))))
- (build-system ruby-build-system)
- (propagated-inputs
- `(("ruby-tdiff" ,ruby-tdiff)
- ("ruby-nokogiri" ,ruby-nokogiri)))
- (native-inputs
- `(("ruby-rspec-2" ,ruby-rspec-2)
- ("ruby-yard" ,ruby-yard)
- ("ruby-rubygems-tasks" ,ruby-rubygems-tasks)))
- (synopsis "Calculate the differences between two XML/HTML documents")
- (description
- "@code{Nokogiri::Diff} adds the ability to calculate the
+ ;; Use a newer than released snapshot so that rspec-2 is not required.
+ (let ((commit "a38491e4d8709b7406f2cae11a50226d927d06f5"))
+ (package
+ (name "ruby-nokogiri-diff")
+ (version (string-append "0.2.0-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/postmodern/nokogiri-diff.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1ah2sfjh9n1p0ln2wkqzfl448ml7j4zfy6dhp1qgzq2m41php6rf"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-tdiff" ,ruby-tdiff)
+ ("ruby-nokogiri" ,ruby-nokogiri)))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("ruby-yard" ,ruby-yard)
+ ("ruby-rubygems-tasks" ,ruby-rubygems-tasks)))
+ (synopsis "Calculate the differences between two XML/HTML documents")
+ (description
+ "@code{Nokogiri::Diff} adds the ability to calculate the
differences (added or removed nodes) between two XML/HTML documents.")
- (home-page "https://github.com/postmodern/nokogiri-diff")
- (license license:expat)))
+ (home-page "https://github.com/postmodern/nokogiri-diff")
+ (license license:expat))))
(define-public ruby-rack
(package