summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 22:19:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:10 +0200
commit58db98c9f213b4010942ea9254d0e877ff95a132 (patch)
tree907c1314f2fb0bff107c0586c541a9965f1a3ded
parent28476b4bc04cf72051a6332734f00c7bd579f740 (diff)
downloadguix-patches-58db98c9f213b4010942ea9254d0e877ff95a132.tar
guix-patches-58db98c9f213b4010942ea9254d0e877ff95a132.tar.gz
gnu: Add r-extremes.
* gnu/packages/cran.scm (r-extremes): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0247963134..b1eb913458 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -638,3 +638,28 @@ interval calculation and to distill pertinent information from a potentially
complex object; primarily used in common with the packages extRemes and
SpatialVx.")
(license license:gpl2+)))
+
+(define-public r-extremes
+ (package
+ (name "r-extremes")
+ (version "2.0-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "extRemes" version))
+ (sha256
+ (base32
+ "0pnpib3g2r9x8hfqhvq23j8m3jh62lp28ipnqir5yadnzv850gfm"))))
+ (properties `((upstream-name . "extRemes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-car" ,r-car)
+ ("r-distillery" ,r-distillery)
+ ("r-lmoments" ,r-lmoments)))
+ (home-page "http://www.assessment.ucar.edu/toolkit/")
+ (synopsis "Extreme value analysis")
+ (description
+ "ExtRemes is a suite of functions for carrying out analyses on the
+extreme values of a process of interest; be they block maxima over long blocks
+or excesses over a high threshold.")
+ (license license:gpl2+)))