summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-10-02 20:59:20 +0200
committerAndreas Enge <andreas@enge.fr>2015-10-02 21:16:02 +0200
commit5768893ad108d53844a525d20a40a39a9006762b (patch)
treee9c660587f02759c93c784b6ca886b0fc7eb4604
parent2f8fee0623e88d3ba17d7cc41510afb3871cf9b7 (diff)
downloadguix-patches-5768893ad108d53844a525d20a40a39a9006762b.tar
guix-patches-5768893ad108d53844a525d20a40a39a9006762b.tar.gz
gnu: valgrind: Enable the arm architecture during configuration.
* gnu/packages/patches/valgrind-enable-arm.patch: New file. * gnu/packages/valgrind.scm (valgrind)[source]: Add patch. * gnu-system.am (dist_patch_DATA): Enable patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/valgrind-enable-arm.patch15
-rw-r--r--gnu/packages/valgrind.scm3
3 files changed, 18 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index c9a4d32475..0afe345809 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -647,6 +647,7 @@ dist_patch_DATA = \
gnu/packages/patches/unzip-remove-build-date.patch \
gnu/packages/patches/util-linux-tests.patch \
gnu/packages/patches/upower-builddir.patch \
+ gnu/packages/patches/valgrind-enable-arm.patch \
gnu/packages/patches/vpnc-script.patch \
gnu/packages/patches/vtk-mesa-10.patch \
gnu/packages/patches/w3m-fix-compile.patch \
diff --git a/gnu/packages/patches/valgrind-enable-arm.patch b/gnu/packages/patches/valgrind-enable-arm.patch
new file mode 100644
index 0000000000..663e68463c
--- /dev/null
+++ b/gnu/packages/patches/valgrind-enable-arm.patch
@@ -0,0 +1,15 @@
+Accept "arm" instead of "armv7" in configure, see
+ http://valgrind.10908.n7.nabble.com/building-for-arm-td39382.html .
+
+diff -u -r valgrind-3.11.0.orig/configure valgrind-3.11.0/configure
+--- valgrind-3.11.0.orig/configure 2015-10-02 20:37:41.915721386 +0200
++++ valgrind-3.11.0/configure 2015-10-02 20:37:54.886746395 +0200
+@@ -5607,7 +5607,7 @@
+ ARCH_MAX="s390x"
+ ;;
+
+- armv7*)
++ arm*)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: ok (${host_cpu})" >&5
+ $as_echo "ok (${host_cpu})" >&6; }
+ ARCH_MAX="arm"
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index f300d93271..5cfbe6d554 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -37,7 +37,8 @@
version ".tar.bz2"))
(sha256
(base32
- "0hiv871b9bk689mv42mkhp76za78l5773glszfkdbpf1m1qn4fbc"))))
+ "0hiv871b9bk689mv42mkhp76za78l5773glszfkdbpf1m1qn4fbc"))
+ (patches (map search-patch '("valgrind-enable-arm.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after