summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-08 20:06:14 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:28:08 +0100
commit533c95bc17cd253455be077a54b1435d0c60950c (patch)
tree33b8366cf84f31d3723982a055d9a6d1caa7bea4
parent565df8a2678336ca527642fb575fde9046862093 (diff)
downloadguix-patches-533c95bc17cd253455be077a54b1435d0c60950c.tar
guix-patches-533c95bc17cd253455be077a54b1435d0c60950c.tar.gz
gnu: Add choqok.
* gnu/packages/kde-internet.scm: New file. * gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch: New file. * gnu/lokal.mk: Add them.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/kde-internet.scm94
-rw-r--r--gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch89
3 files changed, 185 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 912809b74d..da3291fdc6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -283,6 +283,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/kawa.scm \
%D%/packages/kde.scm \
%D%/packages/kde-frameworks.scm \
+ %D%/packages/kde-internet.scm \
%D%/packages/kde-multimedia.scm \
%D%/packages/kde-pim.scm \
%D%/packages/kde-plasma.scm \
@@ -771,6 +772,7 @@ dist_patch_DATA = \
%D%/packages/patches/ceph-disable-cpu-optimizations.patch \
%D%/packages/patches/ceph-volume-respect-PATH.patch \
%D%/packages/patches/chmlib-inttypes.patch \
+ %D%/packages/patches/choqok-Fix-building-under-Qt-5.13.patch \
%D%/packages/patches/clamav-config-llvm-libs.patch \
%D%/packages/patches/clamav-system-tomsfastmath.patch \
%D%/packages/patches/clang-3.5-libc-search-path.patch \
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
new file mode 100644
index 0000000000..4b382df2e7
--- /dev/null
+++ b/gnu/packages/kde-internet.scm
@@ -0,0 +1,94 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-internet)
+ #:use-module (guix build-system qt)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages kde)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-pim)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages web))
+
+(define-public choqok
+ (package
+ (name "choqok")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/choqok/"
+ (version-major+minor version)
+ "/src/choqok-" version ".tar.xz"))
+ (sha256
+ (base32 "03ri4y1wzyqlixnhczsls5gmy7jzzm67bb5gz8bav51ngc32fxca"))
+ (patches (search-patches "choqok-Fix-building-under-Qt-5.13.patch"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("attica" ,attica)
+ ("kcmutils" ,kcmutils)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdewebkit" ,kdewebkit)
+ ("kemoticons" ,kemoticons)
+ ("kglobalaccel" ,kglobalaccel)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kparts" ,kparts)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwallet" ,kwallet)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ;; TODO: telepathy
+ ("oxygen-icons" ,oxygen-icons) ; default icon set
+ ("qca" ,qca)
+ ("qoauth" ,qoauth)
+ ("qtbase" ,qtbase)
+ ("qtwebkit" ,qtwebkit)
+ ("sonnet" ,sonnet)))
+ (home-page "https://kde.org/applications/internet/org.kde.choqok")
+ (synopsis "Micro-Blogging Client")
+ (description "Choqok is a fast, efficient and simple to use micro-blogging
+client for KDE. It currently supports the twitter.com and identi.ca
+microblogging services.
+
+Other notable features include:
+@itemize
+@item Support for user + friends time-lines.
+@item Support for @Reply time-lines.
+@item Support for sending and receiving direct messages.
+@item Twitpic.com integration.
+@item The ability to use multiple accounts simultaneously.
+@item Support for search APIs for all services.
+@item KWallet integration.
+@item Support for automatic shortening urls with more than 30 characters.
+@item Support for configuring status lists appearance.
+@end itemize")
+ (license license:gpl3+)))
diff --git a/gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch b/gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch
new file mode 100644
index 0000000000..4250106a19
--- /dev/null
+++ b/gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch
@@ -0,0 +1,89 @@
+Add QMap include to fix building under Qt 5.13
+
+This combines several patches which all add the same missing include:
+- e13ab06f65a4e8b6259bccda1401abb9c1c9fdca
+- 546ede9ef712bb1b156a55ce30df81c3203dde61
+- 08fb06b63a78888e6703de6ac1a4fd6a0e2791eb
+- bef6784596bf0b41287ebad81f138e1c8c2a6be2
+
+Include is no longer added transitively.
+---
+
+--- a/plugins/betternotify/notify.h
++++ b/plugins/betternotify/notify.h
+@@ -23,6 +23,7 @@
+ #ifndef NOTIFY_H
+ #define NOTIFY_H
+
++#include <QMap>
+ #include <QQueue>
+ #include <QPoint>
+ #include <QPointer>
+--- a/plugins/untiny/untiny.h
++++ b/plugins/untiny/untiny.h
+@@ -27,6 +27,7 @@
+
+ #include "plugin.h"
+
++#include <QMap>
+ #include <QQueue>
+ #include <QUrl>
+ #include <QPointer>
+--- a/plugins/uploaders/flickr/flickr.h
++++ b/plugins/uploaders/flickr/flickr.h
+@@ -26,6 +26,8 @@
+
+ #include "uploader.h"
+
++#include <QMap>
++
+ /**
+ @author Andrey Esin \<gmlastik@gmail.com\>
+ */
+diff --git a/plugins/uploaders/imageshack/imageshack.h b/plugins/uploaders/imageshack/imageshack.h
+index d9ddc88..63d0e3f 100644
+--- a/plugins/uploaders/imageshack/imageshack.h
++++ b/plugins/uploaders/imageshack/imageshack.h
+@@ -26,6 +26,8 @@
+
+ #include "uploader.h"
+
++#include <QMap>
++
+ /**
+ @author Mehrdad Momeny \<mehrdad.momeny@gmail.com\>
+ */
+--- a/plugins/uploaders/mobypicture/mobypicture.h
++++ b/plugins/uploaders/mobypicture/mobypicture.h
+@@ -26,6 +26,8 @@
+
+ #include "uploader.h"
+
++#include <QMap>
++
+ class KJob;
+
+ class Mobypicture : public Choqok::Uploader
+--- a/plugins/uploaders/posterous/posterous.h
++++ b/plugins/uploaders/posterous/posterous.h
+@@ -26,6 +26,8 @@
+
+ #include "uploader.h"
+
++#include <QMap>
++
+ class KJob;
+
+ class Posterous : public Choqok::Uploader
+--- a/plugins/uploaders/twitgoo/twitgoo.h
++++ b/plugins/uploaders/twitgoo/twitgoo.h
+@@ -26,6 +26,8 @@
+
+ #include "uploader.h"
+
++#include <QMap>
++
+ class KJob;
+
+ class Twitgoo : public Choqok::Uploader
+--