summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-28 22:33:21 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-05 14:11:15 +0200
commit52a23d8e4872f5cb313d4456fc3e4c56280a2918 (patch)
treeedaff4e0818476c13c50998e734cbd25eab06e8c
parenta0570377b8a890a13508bb3e9151a78bc7cde84c (diff)
downloadguix-patches-52a23d8e4872f5cb313d4456fc3e4c56280a2918.tar
guix-patches-52a23d8e4872f5cb313d4456fc3e4c56280a2918.tar.gz
gnu: Add java-junitparams.
* gnu/packages/java.scm (java-junitparams): New variable.
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 4dbf27034d..113108eb58 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3735,6 +3735,37 @@ JUnit provides assertions for testing expected results, test fixtures for
sharing common test data, and test runners for running tests.")
(license license:epl1.0)))
+(define-public java-junitparams
+ (package
+ (name "java-junitparams")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Pragmatists/JUnitParams")
+ (commit (string-append "JUnitParams-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rb52xdfp99invyjrras3w0bf0a81cz30yd47rkkiyqcqj0y1q9b"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "junitparams.jar"
+ #:source-dir "src/main/java"
+ #:test-dir "src/test"
+ #:test-exclude (list "**/SuperclassTest.java")))
+ (inputs
+ `(("java-junit" ,java-junit)))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)
+ ("java-assertj" ,java-assertj)))
+ (home-page "https://github.com/Pragmatists/JUnitParams")
+ (synopsis "Parameterised test support for JUnit")
+ (description "The JUnitParams project adds a new runner to JUnit and
+provides much easier and readable parametrised tests for JUnit.")
+ (license license:asl2.0)))
+
(define-public java-plexus-utils
(package
(name "java-plexus-utils")