summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 11:30:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:20 +0300
commit52811a7609af634188cc2cfe4be96feb64c47a3c (patch)
tree8e37dec4c37443e416b7f53a84570b46374bdf2d
parent9810337bb6596478c1ea15786199dc32df8be2e5 (diff)
downloadguix-patches-52811a7609af634188cc2cfe4be96feb64c47a3c.tar
guix-patches-52811a7609af634188cc2cfe4be96feb64c47a3c.tar.gz
gnu: Add julia-deepdiffs.
* gnu/packages/julia-xyz.scm (julia-deepdiffs): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7af40816ff..e2f5bdb9ec 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -727,6 +727,29 @@ without having to take direct dependencies.")
to represent missing data.")
(license license:expat)))
+(define-public julia-deepdiffs
+ (package
+ (name "julia-deepdiffs")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ssfrr/DeepDiffs.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gsbxb1d67g05h5bvzz3swdfih6404jrydy724a8dvbdgqvm3sds"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/ssfrr/DeepDiffs.jl")
+ (synopsis "Compute and pretty-print diffs for data structures")
+ (description "@code{DeepDiffs.jl} provides the @code{deepdiff} function,
+which finds and displays differences (diffs) between Julia data structures. It
+supports @code{Vectors}, @code{Dicts}, and @code{String}s. When diffing
+dictionaries where values associated with a particular key may change,
+@code{deepdiff} will recurse into value to provide a more detailed diff.")
+ (license license:expat)))
+
(define-public julia-dictionaries
(package
(name "julia-dictionaries")