summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-15 17:42:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 17:45:33 +0100
commit4fec042b54d65a2f44cc3602f7d6f82292e3d1a9 (patch)
treef520114b54f9428d0e52ffd423070286d885be43
parent22e623aef08cc08c14073dca0193e9238ca88e9e (diff)
downloadguix-patches-4fec042b54d65a2f44cc3602f7d6f82292e3d1a9.tar
guix-patches-4fec042b54d65a2f44cc3602f7d6f82292e3d1a9.tar.gz
gnu: Move Python compression packages to new module.
* gnu/packages/compression.scm (python-lzo, python2-lzo, python-lz4, python2-lz4, python-lzstring, python2-lzstring, bitshuffle, bitshuffle-for-snappy): Move variables from here... * gnu/packages/python-compression.scm: ...to this new module. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/bioinformatics.scm, gnu/packages/java-compression.scm, gnu/packages/xorg.scm: Adjust module references.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm1
-rw-r--r--gnu/packages/compression.scm173
-rw-r--r--gnu/packages/java-compression.scm3
-rw-r--r--gnu/packages/python-compression.scm206
-rw-r--r--gnu/packages/xorg.scm1
6 files changed, 211 insertions, 174 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7ee41de644..fb8e0e1eb0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -367,6 +367,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/pure.scm \
%D%/packages/pv.scm \
%D%/packages/python.scm \
+ %D%/packages/python-compression.scm \
%D%/packages/python-crypto.scm \
%D%/packages/python-web.scm \
%D%/packages/python-xyz.scm \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1254d21c87..28dbdca13b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -98,6 +98,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 956cac7a1f..327951fded 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -47,7 +47,6 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
@@ -61,7 +60,6 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (ice-9 match)
@@ -462,44 +460,6 @@ LZO is written in ANSI C. Both the source code and the compressed data
format are designed to be portable across platforms.")
(license license:gpl2+)))
-(define-public python-lzo
- (package
- (name "python-lzo")
- (version "1.12")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-lzo" version))
- (sha256
- (base32
- "0iakqgd51n1cd7r3lpdylm2rgbmd16y74cra9kcapwg84mlf9a4p"))))
- (build-system python-build-system)
- (arguments
- `(#:test-target "check"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-setuppy
- (lambda _
- (substitute* "setup.py"
- (("include_dirs.append\\(.*\\)")
- (string-append "include_dirs.append('"
- (assoc-ref %build-inputs "lzo")
- "/include/lzo"
- "')")))
- #t)))))
- (inputs
- `(("lzo" ,lzo)))
- (home-page "https://github.com/jd-boyd/python-lzo")
- (synopsis "Python bindings for the LZO data compression library")
- (description
- "Python-LZO provides Python bindings for LZO, i.e. you can access
-the LZO library from your Python scripts thereby compressing ordinary
-Python strings.")
- (license license:gpl2+)))
-
-(define-public python2-lzo
- (package-with-python2 python-lzo))
-
(define-public lzop
(package
(name "lzop")
@@ -741,54 +701,6 @@ time for compression ratio.")
;; line interface programs (lz4, fullbench, fuzzer, datagen) are GPL2+.
(license (list license:bsd-2 license:gpl2+))))
-(define-public python-lz4
- (package
- (name "python-lz4")
- (version "0.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "lz4" version))
- (sha256
- (base32
- "0ghv1xbaq693kgww1x9c22bplz479ls9szjsaa4ig778ls834hm0"))))
- (build-system python-build-system)
- (native-inputs
- `(("python-nose" ,python-nose)
- ("python-setuptools-scm" ,python-setuptools-scm)))
- (home-page "https://github.com/python-lz4/python-lz4")
- (synopsis "LZ4 bindings for Python")
- (description
- "This package provides python bindings for the lz4 compression library
-by Yann Collet. The project contains bindings for the LZ4 block format and
-the LZ4 frame format.")
- (license license:bsd-3)))
-
-(define-public python2-lz4
- (package-with-python2 python-lz4))
-
-(define-public python-lzstring
- (package
- (name "python-lzstring")
- (version "1.0.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "lzstring" version))
- (sha256
- (base32
- "18ly9pppy2yspxzw7k1b23wk77k7m44rz2g0271bqgqrk3jn3yhs"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-future" ,python-future)))
- (home-page "https://github.com/gkovacs/lz-string-python")
- (synopsis "String compression")
- (description "Lz-string is a string compressor library for Python.")
- (license license:expat)))
-
-(define-public python2-lzstring
- (package-with-python2 python-lzstring))
-
(define-public squashfs-tools
(package
(name "squashfs-tools")
@@ -1118,54 +1030,6 @@ well as bzip2.")
(license (list license:gpl3+
license:public-domain)))) ; most files in lzma/
-(define-public bitshuffle
- (package
- (name "bitshuffle")
- (version "0.3.5")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "bitshuffle" version))
- (sha256
- (base32
- "1823x61kyax4dc2hjmc1xraskxi1193y8lvxd03vqv029jrj8cjy"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove generated Cython files.
- (delete-file "bitshuffle/h5.c")
- (delete-file "bitshuffle/ext.c")
- #t))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f ; fail: https://github.com/h5py/h5py/issues/769
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-neon-detection
- ;; Neon is only for aarch64 ATM
- ;; see: https://github.com/kiyo-masui/bitshuffle/pull/73
- (lambda _
- (substitute* "src/bitshuffle_core.c"
- (("#define USEARMNEON")
- "#ifdef __aarch64__\n#define USEARMNEON\n#endif"))
- #t))
- (add-after 'unpack 'dont-build-native
- (lambda _
- (substitute* "setup.py"
- (("'-march=native', ") ""))
- #t)))))
- (inputs
- `(("numpy" ,python-numpy)
- ("h5py" ,python-h5py)
- ("hdf5" ,hdf5)))
- (native-inputs
- `(("cython" ,python-cython)))
- (home-page "https://github.com/kiyo-masui/bitshuffle")
- (synopsis "Filter for improving compression of typed binary data")
- (description "Bitshuffle is an algorithm that rearranges typed, binary data
-for improving compression, as well as a python/C package that implements this
-algorithm within the Numpy framework.")
- (license license:expat)))
-
(define-public snappy
(package
(name "snappy")
@@ -1192,43 +1056,6 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
100% bigger.")
(license license:asl2.0)))
-(define-public bitshuffle-for-snappy
- (package
- (inherit bitshuffle)
- (name "bitshuffle-for-snappy")
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (with-output-to-file "Makefile"
- (lambda _
- (format #t "\
-libbitshuffle.so: src/bitshuffle.o src/bitshuffle_core.o src/iochain.o lz4/lz4.o
-\tgcc -O3 -ffast-math -std=c99 -o $@ -shared -fPIC $^
-
-%.o: %.c
-\tgcc -O3 -ffast-math -std=c99 -fPIC -Isrc -Ilz4 -c $< -o $@
-
-PREFIX:=~a
-LIBDIR:=$(PREFIX)/lib
-INCLUDEDIR:=$(PREFIX)/include
-
-install: libbitshuffle.so
-\tinstall -dm755 $(LIBDIR)
-\tinstall -dm755 $(INCLUDEDIR)
-\tinstall -m755 libbitshuffle.so $(LIBDIR)
-\tinstall -m644 src/bitshuffle.h $(INCLUDEDIR)
-\tinstall -m644 src/bitshuffle_core.h $(INCLUDEDIR)
-\tinstall -m644 src/iochain.h $(INCLUDEDIR)
-\tinstall -m644 lz4/lz4.h $(INCLUDEDIR)
-" (assoc-ref outputs "out"))))
- #t)))))
- (inputs '())
- (native-inputs '())))
-
(define-public p7zip
(package
(name "p7zip")
diff --git a/gnu/packages/java-compression.scm b/gnu/packages/java-compression.scm
index 8cebfc65a5..3102c70d88 100644
--- a/gnu/packages/java-compression.scm
+++ b/gnu/packages/java-compression.scm
@@ -29,7 +29,8 @@
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages java)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages python-compression))
(define-public java-snappy
(package
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
new file mode 100644
index 0000000000..3792f37328
--- /dev/null
+++ b/gnu/packages/python-compression.scm
@@ -0,0 +1,206 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages python-compression)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz))
+
+(define-public python-lzo
+ (package
+ (name "python-lzo")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-lzo" version))
+ (sha256
+ (base32
+ "0iakqgd51n1cd7r3lpdylm2rgbmd16y74cra9kcapwg84mlf9a4p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setuppy
+ (lambda _
+ (substitute* "setup.py"
+ (("include_dirs.append\\(.*\\)")
+ (string-append "include_dirs.append('"
+ (assoc-ref %build-inputs "lzo")
+ "/include/lzo"
+ "')")))
+ #t)))))
+ (inputs
+ `(("lzo" ,lzo)))
+ (home-page "https://github.com/jd-boyd/python-lzo")
+ (synopsis "Python bindings for the LZO data compression library")
+ (description
+ "Python-LZO provides Python bindings for LZO, i.e. you can access
+the LZO library from your Python scripts thereby compressing ordinary
+Python strings.")
+ (license license:gpl2+)))
+
+(define-public python2-lzo
+ (package-with-python2 python-lzo))
+
+(define-public python-lz4
+ (package
+ (name "python-lz4")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lz4" version))
+ (sha256
+ (base32
+ "0ghv1xbaq693kgww1x9c22bplz479ls9szjsaa4ig778ls834hm0"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/python-lz4/python-lz4")
+ (synopsis "LZ4 bindings for Python")
+ (description
+ "This package provides python bindings for the lz4 compression library
+by Yann Collet. The project contains bindings for the LZ4 block format and
+the LZ4 frame format.")
+ (license license:bsd-3)))
+
+(define-public python2-lz4
+ (package-with-python2 python-lz4))
+
+(define-public python-lzstring
+ (package
+ (name "python-lzstring")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lzstring" version))
+ (sha256
+ (base32
+ "18ly9pppy2yspxzw7k1b23wk77k7m44rz2g0271bqgqrk3jn3yhs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-future" ,python-future)))
+ (home-page "https://github.com/gkovacs/lz-string-python")
+ (synopsis "String compression")
+ (description "Lz-string is a string compressor library for Python.")
+ (license license:expat)))
+
+(define-public python2-lzstring
+ (package-with-python2 python-lzstring))
+
+(define-public bitshuffle
+ (package
+ (name "bitshuffle")
+ (version "0.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "bitshuffle" version))
+ (sha256
+ (base32
+ "1823x61kyax4dc2hjmc1xraskxi1193y8lvxd03vqv029jrj8cjy"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove generated Cython files.
+ (delete-file "bitshuffle/h5.c")
+ (delete-file "bitshuffle/ext.c")
+ #t))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; fail: https://github.com/h5py/h5py/issues/769
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-neon-detection
+ ;; Neon is only for aarch64 ATM
+ ;; see: https://github.com/kiyo-masui/bitshuffle/pull/73
+ (lambda _
+ (substitute* "src/bitshuffle_core.c"
+ (("#define USEARMNEON")
+ "#ifdef __aarch64__\n#define USEARMNEON\n#endif"))
+ #t))
+ (add-after 'unpack 'dont-build-native
+ (lambda _
+ (substitute* "setup.py"
+ (("'-march=native', ") ""))
+ #t)))))
+ (inputs
+ `(("numpy" ,python-numpy)
+ ("h5py" ,python-h5py)
+ ("hdf5" ,hdf5)))
+ (native-inputs
+ `(("cython" ,python-cython)))
+ (home-page "https://github.com/kiyo-masui/bitshuffle")
+ (synopsis "Filter for improving compression of typed binary data")
+ (description "Bitshuffle is an algorithm that rearranges typed, binary data
+for improving compression, as well as a python/C package that implements this
+algorithm within the Numpy framework.")
+ (license license:expat)))
+
+(define-public bitshuffle-for-snappy
+ (package
+ (inherit bitshuffle)
+ (name "bitshuffle-for-snappy")
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "Makefile"
+ (lambda _
+ (format #t "\
+libbitshuffle.so: src/bitshuffle.o src/bitshuffle_core.o src/iochain.o lz4/lz4.o
+\tgcc -O3 -ffast-math -std=c99 -o $@ -shared -fPIC $^
+
+%.o: %.c
+\tgcc -O3 -ffast-math -std=c99 -fPIC -Isrc -Ilz4 -c $< -o $@
+
+PREFIX:=~a
+LIBDIR:=$(PREFIX)/lib
+INCLUDEDIR:=$(PREFIX)/include
+
+install: libbitshuffle.so
+\tinstall -dm755 $(LIBDIR)
+\tinstall -dm755 $(INCLUDEDIR)
+\tinstall -m755 libbitshuffle.so $(LIBDIR)
+\tinstall -m644 src/bitshuffle.h $(INCLUDEDIR)
+\tinstall -m644 src/bitshuffle_core.h $(INCLUDEDIR)
+\tinstall -m644 src/iochain.h $(INCLUDEDIR)
+\tinstall -m644 lz4/lz4.h $(INCLUDEDIR)
+" (assoc-ref outputs "out"))))
+ #t)))))
+ (inputs '())
+ (native-inputs '())))
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a6a2e603aa..67b38246ec 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -71,6 +71,7 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)