summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-27 21:01:27 -0400
committerMark H Weaver <mhw@netris.org>2018-11-14 23:44:02 -0500
commit4851af9ebe3949354a2d22ca932bbecb072c5024 (patch)
tree2f184da542879160b07bdacd8977e7d51339b089
parent366c1cbbc623fd94de05bde7c67e61ec0360aded (diff)
downloadguix-patches-4851af9ebe3949354a2d22ca932bbecb072c5024.tar
guix-patches-4851af9ebe3949354a2d22ca932bbecb072c5024.tar.gz
gnu: perl: Return #t from all phases.
* gnu/packages/gd.scm (perl-gd-securityimage) * gnu/packages/libevent.scm (perl-ev) * gnu/packages/markup.scm (perl-text-markdown-discount) * gnu/packages/perl-check.scm (perl-test2-bundle-extended) * gnu/packages/perl.scm (perl-digest-md5, perl-encode-hanextra) (perl-ipc-run, perl-pathtools) * gnu/packages/photo.scm (perl-image-exiftool): Return #t from all phases.
-rw-r--r--gnu/packages/gd.scm2
-rw-r--r--gnu/packages/markup.scm3
-rw-r--r--gnu/packages/perl-check.scm2
-rw-r--r--gnu/packages/perl.scm11
-rw-r--r--gnu/packages/photo.scm3
5 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 1fe69577fd..a53a4f2c2f 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -142,7 +142,7 @@ you can create PNG images on the fly or modify existing files.")
'(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-env
- (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
(native-inputs
`(("perl-module-build" ,perl-module-build)))
(propagated-inputs
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index cdcfbc7898..20da258029 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -173,7 +173,8 @@ convert it to structurally valid XHTML (or HTML).")
(string-append
"OTHERLDFLAGS = -lmarkdown -Wl,-rpath="
(assoc-ref inputs "discount")
- "/lib"))))))))
+ "/lib")))
+ #t)))))
(inputs
`(("discount" ,discount)))
(home-page
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 98b4e392c7..d0abb39254 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -82,7 +82,7 @@ lexically, just dynamically.")
'(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-env
- (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
(propagated-inputs
`(("perl-importer" ,perl-importer)
("perl-term-table" ,perl-term-table)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d6ea360b8e..8c854e88df 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2877,7 +2877,8 @@ interface for the RFC 2104 HMAC mechanism.")
(add-after 'build 'set-permissions
(lambda _
;; Make MD5.so read-write so it can be stripped.
- (chmod "blib/arch/auto/Digest/MD5/MD5.so" #o755))))))
+ (chmod "blib/arch/auto/Digest/MD5/MD5.so" #o755)
+ #t)))))
(home-page "https://metacpan.org/release/Digest-MD5")
(synopsis "Perl interface to the MD-5 algorithm")
(description
@@ -3003,7 +3004,7 @@ also known as JIS 2000.")
'(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-env
- (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
(home-page "https://metacpan.org/release/Encode-HanExtra")
(synopsis "Additional Chinese encodings")
(description "This Perl module provides Chinese encodings that are not
@@ -4278,7 +4279,8 @@ run interactively. It also has an option to capture output/error buffers.")
(lambda _
;; This test fails, and we're not really interested in
;; it, so disable it.
- (delete-file "t/win32_compile.t"))))))
+ (delete-file "t/win32_compile.t")
+ #t)))))
(home-page "https://metacpan.org/release/IPC-Run")
(synopsis "Run system() and background procs w/ piping, redirs, ptys")
(description "IPC::Run allows you run and interact with child processes
@@ -6867,7 +6869,8 @@ directory specifications in a cross-platform manner.")
(substitute* "Cwd.pm"
(("'/bin/pwd'")
(string-append "'" (assoc-ref inputs "coreutils")
- "/bin/pwd'"))))))))
+ "/bin/pwd'")))
+ #t)))))
(inputs
`(("coreutils" ,coreutils)))
(home-page "https://metacpan.org/release/PathTools")
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 1cd789b802..713342658b 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -227,7 +227,8 @@ MTP, and much more.")
(pm (find-files out "^ExifTool\\.pm$"))
(lib (dirname (dirname (car pm)))))
(wrap-program (string-append out "/bin/exiftool")
- `("PERL5LIB" prefix (,lib)))))))))
+ `("PERL5LIB" prefix (,lib)))
+ #t))))))
(home-page "https://metacpan.org/release/Image-ExifTool")
(synopsis "Program and Perl library to manipulate EXIF and other metadata")
(description "This package provides the @code{exiftool} command and the