summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2021-06-06 19:55:50 -0400
committerLudovic Courtès <ludo@gnu.org>2021-06-13 23:57:45 +0200
commit483f537081b9b5ccf026373d6743761aba6946e3 (patch)
tree9a85f1b838001f1cf8f30533127dbc1b6957a490
parent44ed008ac127da297f28643df072f908e133b686 (diff)
downloadguix-patches-483f537081b9b5ccf026373d6743761aba6946e3.tar
guix-patches-483f537081b9b5ccf026373d6743761aba6946e3.tar.gz
doc, gnu, guix: Fix typos.
* doc/guix.texi: Fix various typos and reword a sentence. * gnu/packages/cpp.scm (cpplint)[description]: Fix typo. * gnu/packages/dns.scm (ldns): Fix typo in comment. * gnu/packages/games.scm (yamagi-quake2): Fix typo in comment. * gnu/packages/qt.scm (python-pyqtwebengine): Fix typo in comment. * gnu/packages/rails.scm (ruby-autoprefixer-rails): Fix typo in comment. * gnu/packages/syndication.scm (quiterss)[description]: Fix typo. * gnu/packages/terminals.scm (kmscon): Fix typo in comment. * gnu/packages/xml.scm (perl-xml-sax-base)[description]: Fix typo. (python-elementpath)[description]: Fix typo. * guix/build/asdf-build-system.scm (output-translation): Fix typo in docstring. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--doc/guix.texi8
-rw-r--r--gnu/packages/cpp.scm2
-rw-r--r--gnu/packages/dns.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/qt.scm2
-rw-r--r--gnu/packages/rails.scm4
-rw-r--r--gnu/packages/syndication.scm2
-rw-r--r--gnu/packages/terminals.scm2
-rw-r--r--gnu/packages/xml.scm4
-rw-r--r--guix/build/asdf-build-system.scm3
10 files changed, 15 insertions, 16 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 59b4ac11b4..e7c783bd95 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -7807,7 +7807,7 @@ MbedTLS package:
Some older packages that aren't using @file{Package.toml} yet, will require
this file to be created, too. The function @code{julia-create-package-toml}
helps creating the file. You need to pass the outputs and the source of the
-package, it's name (the same as the @code{file-name} parameter), the package
+package, its name (the same as the @code{file-name} parameter), the package
uuid, the package version, and a list of dependencies specified by their name
and their uuid.
@end defvr
@@ -21755,7 +21755,7 @@ Available @code{getmail-options-configuration} fields are:
If set to @samp{0}, getmail will only print warnings and errors. A
value of @samp{1} means that messages will be printed about retrieving
and deleting messages. If set to @samp{2}, getmail will print messages
-about each of it's actions.
+about each of its actions.
Defaults to @samp{1}.
@@ -25502,7 +25502,7 @@ directives} for comprehensive documentation on the acceptable
@deftp {Data type} php-fpm-dynamic-process-manager-configuration
Data Type for the @code{dynamic} php-fpm process manager. With the
@code{dynamic} process manager, spare worker processes are kept around
-based on it's configured limits.
+based on its configured limits.
@table @asis
@item @code{max-children} (default: @code{5})
Maximum of worker processes.
@@ -31570,7 +31570,7 @@ notifications.
The kernel module loader service allows one to load loadable kernel
modules at boot. This is especially useful for modules that don't
-autoload and need to be manually loaded, as it's the case with
+autoload and need to be manually loaded, as is the case with
@code{ddcci}.
@deffn {Scheme Variable} kernel-module-loader-service-type
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3089094eb8..54f9da4b27 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -587,7 +587,7 @@ tools:
(synopsis "Static code checker for C++")
(description "@code{cpplint} is a command-line tool to check C/C++ files
for style issues following Google’s C++ style guide. While Google maintains
-it's own version of the tool, this is a fork that aims to be more responsive
+its own version of the tool, this is a fork that aims to be more responsive
and make @code{cpplint} usable in wider contexts.")
(license license:bsd-3)))
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 641681320c..199b876369 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -101,7 +101,7 @@
(base32 "0ac242n7996fswq1a3nlh1bbbhrsdwsq4mx7xq8ffq6aplb4rj4a"))
(patches
(search-patches
- ;; To create make-flag vairables,
+ ;; To create make-flag variables,
;; for splitting installation of drill and examples.
"ldns-drill-examples.patch"))))
(build-system gnu-build-system)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2eaea5868e..26d3567024 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7151,7 +7151,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(mkdir-p (string-append out "/lib"))
(mkdir-p (string-append out "/bin"))
;; The yamagi-quake2 binary must be in the same directory
- ;; as it's engine libraries, but symlinking it to /bin is okay
+ ;; as its engine libraries, but symlinking it to /bin is okay.
;; https://github.com/yquake2/yquake2/blob/master/stuff/packaging.md
(copy-recursively "release"
(string-append out "/lib/yamagi-quake2"))
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6bb1281570..f992314777 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2068,7 +2068,7 @@ contain over 620 classes.")
"--sipdir" sipdir
"--pyqt-sipdir" pyqt-sipdir))))
;; Because this has a different prefix than python-pyqt then we need
- ;; to make this a namespace of it's own
+ ;; to make this a namespace of its own.
(add-after 'install 'make-namespace
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((__init__.py (string-append
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index e9c390a1a0..76ed4df6e4 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -142,8 +142,8 @@ API.")
(modify-phases %standard-phases
(add-after 'extract-gemspec 'remove-unnecessary-dependencies
(lambda _
- ;; Remove the testing of compass, as it's use is deprecated, and
- ;; it's unpackaged for Guix
+ ;; Remove the testing of compass, as its use is deprecated, and
+ ;; it's unpackaged for Guix.
(substitute* "autoprefixer-rails.gemspec"
((".*%q<compass>.*") "\n")
(("\"spec/compass_spec\\.rb\"\\.freeze, ") ""))
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index fc4efb24f6..9d4325ffdf 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -576,7 +576,7 @@ formats, including all versions of RSS and Atom.")
(home-page "https://quiterss.org/")
(synopsis "RSS/Atom news feeds reader written on Qt/C++")
(description "QuiteRSS is an RSS/Atom news feeds reader written on Qt/C++
-that aims to be quite fast and comfortable to it's user.")
+that aims to be quite fast and comfortable to its user.")
(license license:gpl3+)))
(define-public gfeeds
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 37636c7cdc..06ace5e238 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -326,7 +326,7 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
("libxkbcommon" ,libxkbcommon)
("logind" ,elogind)
;; MESA can be used for accelerated video output via OpenGLESv2, but
- ;; it's a bit dependency that we'd rather avoid in the installation
+ ;; it's a big dependency that we'd rather avoid in the installation
;; image.
;; ("mesa" ,mesa)
("pango" ,pango)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9ddd02a613..e2d5ca8176 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -878,7 +878,7 @@ building Perl SAX2 XML parsers, filters, and drivers.")
(home-page "https://metacpan.org/release/XML-SAX-Base")
(synopsis "Base class for SAX Drivers and Filters")
(description "This module has a very simple task - to be a base class for
-PerlSAX drivers and filters. It's default behaviour is to pass the input
+PerlSAX drivers and filters. Its default behaviour is to pass the input
directly to the output unchanged. It can be useful to use this module as a
base class so you don't have to, for example, implement the characters()
callback.")
@@ -2587,7 +2587,7 @@ for Python's ElementTree XML data structures, both for the standard
ElementTree library and for the @uref{http://lxml.de, lxml.etree} library.
For lxml.etree this package can be useful for providing XPath 2.0 selectors,
-because lxml.etree already has it's own implementation of XPath 1.0.")
+because lxml.etree already has its own implementation of XPath 1.0.")
(license license:expat)))
(define-public python-lxml
diff --git a/guix/build/asdf-build-system.scm b/guix/build/asdf-build-system.scm
index 7f1037c4f9..6186613e52 100644
--- a/guix/build/asdf-build-system.scm
+++ b/guix/build/asdf-build-system.scm
@@ -72,8 +72,7 @@
(define (output-translation source-path
object-output)
- "Return a translation for the system's source path
-to it's binary output."
+ "Return a translation for the system's source path to its binary output."
`((,source-path
:**/ :*.*.*)
(,(library-directory object-output)