summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 12:12:59 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:42 +0200
commit433bb35336a2e583d1f8559407e0fc68b597fae8 (patch)
tree64ee2b093548a9e46d1d3ee282358ff4474ad6d1
parent63a1783d3a0bdd4295117d8de5dbcfe6b04f6781 (diff)
downloadguix-patches-433bb35336a2e583d1f8559407e0fc68b597fae8.tar
guix-patches-433bb35336a2e583d1f8559407e0fc68b597fae8.tar.gz
gnu: Add libnice.
* gnu/packages/networking.scm (libnice): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/networking.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b92ac4b018..c197b40040 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -95,6 +95,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libevent)
@@ -106,6 +107,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages nettle)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
@@ -135,6 +137,60 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public libnice
+ (package
+ (name "libnice")
+ (version "0.1.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://libnice.freedesktop.org/releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09lm0rxwvbr53svi3inaharlq96iwbs3s6957z69qp4bqpga0lhr"))))
+ (build-system meson-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ (list
+ "-Dgtk_doc=enabled")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ #t))))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("libnsl" ,libnsl)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("glib-networking" ,glib-networking)))
+ (synopsis "GLib ICE implementation")
+ (description "LibNice is a library that implements the Interactive
+Connectivity Establishment (ICE) standard (RFC 5245 & RFC 8445). It provides a
+GLib-based library, libnice, as well as GStreamer elements to use it.")
+ (home-page "https://libnice.freedesktop.org/")
+ (license
+ ;; This project is dual-licensed.
+ (list
+ license:lgpl2.1+
+ license:mpl1.1))))
+
(define-public rtmpdump
(package
(name "rtmpdump")