summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 01:20:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 12:02:52 +0100
commit3fd74c45064eba882771b0398b4c3b29b030a44a (patch)
treef8adb52249cbe153a82a424ec9243e9c905999c0
parent704f1b53c77f3550bc7b3e86aa7237db2fc1594e (diff)
downloadguix-patches-3fd74c45064eba882771b0398b4c3b29b030a44a.tar
guix-patches-3fd74c45064eba882771b0398b4c3b29b030a44a.tar.gz
gnu: jbig2dec: Update to 0.18.
* gnu/packages/patches/jbig2dec-ignore-testtest.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/image.scm (jbig2dec): Update to 0.18. [source](uri): Adjust for Ghostscript 9.51. [source](patches): Remove. [arguments]: Add #:phases. [native-inputs]: Add AUTOCONF, AUTOMAKE, LIBTOOL and PYTHON-WRAPPER.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image.scm25
-rw-r--r--gnu/packages/patches/jbig2dec-ignore-testtest.patch16
3 files changed, 20 insertions, 22 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 47279ffa08..d5271067d6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1053,7 +1053,6 @@ dist_patch_DATA = \
%D%/packages/patches/java-xerces-bootclasspath.patch \
%D%/packages/patches/java-xerces-build_dont_unzip.patch \
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
- %D%/packages/patches/jbig2dec-ignore-testtest.patch \
%D%/packages/patches/jfsutils-add-sysmacros.patch \
%D%/packages/patches/jfsutils-include-systypes.patch \
%D%/packages/patches/jsoncpp-fix-inverted-case.patch \
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 36f650f23a..3850e7fb77 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -635,18 +635,33 @@ arithmetic ops.")
(define-public jbig2dec
(package
(name "jbig2dec")
- (version "0.17")
+ (version "0.18")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ArtifexSoftware"
"/ghostpdl-downloads/releases/download"
- "/gs950/" name "-" version ".tar.gz"))
+ "/gs951/" name "-" version ".tar.gz"))
(sha256
(base32
- "0wpvslmwazia3z8gyk343kbq6yj47pxr4x5yjvx332v309qssazp"))
- (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
+ "0pigfw2v0ppvr0lbysm69gx0zsa5q2q92yrb8af2j3im6x97f6cy"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--disable-static")))
+ (arguments '(#:configure-flags '("--disable-static")
+ #:phases (modify-phases %standard-phases
+ (add-before 'bootstrap 'force-bootstrap
+ (lambda _
+ ;; XXX: jbig2dec 0.18 was released with
+ ;; a broken configure script, so we
+ ;; recreate the build system here.
+ ;; Remove the autoconf inputs below
+ ;; when deleting this code.
+ (delete-file "configure")
+ (delete-file "autogen.sh")
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("python" ,python-wrapper))) ;for tests
(synopsis "Decoder of the JBIG2 image compression format")
(description
"JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
diff --git a/gnu/packages/patches/jbig2dec-ignore-testtest.patch b/gnu/packages/patches/jbig2dec-ignore-testtest.patch
deleted file mode 100644
index 7c80c545e9..0000000000
--- a/gnu/packages/patches/jbig2dec-ignore-testtest.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Do not run the test 'test_jbig2dec.py'. It doesn't seem to do anything
-and reports failure. TODO: Actually fix the test instead of ignoring it.
-
-diff --git a/Makefile.in b/Makefile.in
-index 63982d4..8af1d61 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -93,7 +93,7 @@ host_triplet = @host@
- bin_PROGRAMS = jbig2dec$(EXEEXT)
- noinst_PROGRAMS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
- test_arith$(EXEEXT)
--TESTS = test_sha1$(EXEEXT) test_jbig2dec.py test_huffman$(EXEEXT) \
-+TESTS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
- test_arith$(EXEEXT)
- subdir = .
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4