summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-23 18:15:46 +0100
committerMarius Bakke <marius@gnu.org>2022-02-13 15:15:56 +0100
commit3f571aa4e496acbe221907d837dabf8e1c55d4c2 (patch)
tree51a8b8f133f6561cb703e64bb8f75b0698848507
parentf0b4c042ffe5f6c2bb5e891ca7f8c3a8db7eacdc (diff)
downloadguix-patches-3f571aa4e496acbe221907d837dabf8e1c55d4c2.tar
guix-patches-3f571aa4e496acbe221907d837dabf8e1c55d4c2.tar.gz
gnu: python-requests: Remove unnecessary input.
* gnu/packages/python-web.scm (python-requests)[propagated-inputs]: Remove PYTHON-CHARDET. (python2-requests)[propagated-inputs]: Add PYTHON2-CHARDET.
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1fef103ffe..ffb899ccd2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2541,8 +2541,10 @@ APIs.")
"0qcsbi919d689xqlgyhw9zkppp1fs6k09wwffa3ri6d8smpwbmv8"))))
(build-system python-build-system)
(propagated-inputs
- (list python-certifi python-chardet python-charset-normalizer
- python-idna python-urllib3))
+ (list python-certifi
+ python-charset-normalizer
+ python-idna
+ python-urllib3))
(arguments
;; FIXME: Some tests require network access.
'(#:tests? #f))
@@ -2561,6 +2563,7 @@ than Python’s urllib2 library.")
;; The python-charset-normalizer dependency is necessary on Python 3
;; only.
(propagated-inputs (modify-inputs (package-propagated-inputs base)
+ (append python2-chardet)
(delete "python-charset-normalizer"))))))
(define-public python-requests-unixsocket