summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-23 17:52:22 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-29 12:37:31 +0200
commit3c1e1ec10783132b108e278e8ca345b1b6f49ca2 (patch)
tree1a0c6bd4321125cbcaf6148f719be054cdc56017
parent94bae22204c21bb3d3a3d7d6c2881dfbef44774d (diff)
downloadguix-patches-3c1e1ec10783132b108e278e8ca345b1b6f49ca2.tar
guix-patches-3c1e1ec10783132b108e278e8ca345b1b6f49ca2.tar.gz
gnu: python2-larch: Remove package.
* gnu/packages/python-xyz.scm (python2-larch): Remove variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1aa53b7825..800a49bc93 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17269,50 +17269,6 @@ matters when code is run in production mode. The actual logging still
happens using the @code{logging} library.")
(license license:gpl3+)))
-(define-public python2-larch
- (package
- (name "python2-larch")
- (version "1.20151025")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://git.liw.fi/cgi-bin/cgit/cgit.cgi/larch/snapshot/larch-"
- version ".tar.gz"))
- (patches (search-patches
- "python2-larch-coverage-4.0a6-compatibility.patch"))
- (sha256
- (base32
- "1p4knkkavlqymgciz2wbcnfrdgdbafhg14maplnk4vbw0q8xs663"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; check phase needs to be run before the build phase. If not,
- ;; coverage-test-runner looks for tests for the built source files,
- ;; and fails.
- (delete 'check)
- (add-before 'build 'check
- (lambda _ (invoke "make" "check"))))))
- (native-inputs
- `(("cmdtest" ,cmdtest)
- ("python2-coverage-test-runner" ,python2-coverage-test-runner)))
- (propagated-inputs
- `(("python2-tracing" ,python2-tracing)))
- (home-page "https://liw.fi/larch/")
- (synopsis "Python copy-on-write B-tree library")
- (description "@code{python2-larch} is an implementation of
-particular kind of B-tree, based on research by Ohad Rodeh. See
-@url{http://liw.fi/larch/ohad-btrees-shadowing-clones.pdf} for details
-on the data structure.
-
-The distinctive feature of this B-tree is that a node is never
-(conceptually) modified. Instead, all updates are done by
-copy-on-write. This makes it easy to clone a tree, and modify only the
-clone, while other processes access the original tree.")
- (license license:gpl3+)))
-
(define-public python-astroid
(package
(name "python-astroid")