summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-01-04 01:30:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-01-04 05:14:22 +0100
commit3b3b60d0370f0a93be075341152b623d58632fa2 (patch)
tree194e5ab27412e558a5d7574a4de550ca6a0e8a5b
parent0916dc526e77f61d19895c9951c8d47d15c4941d (diff)
downloadguix-patches-3b3b60d0370f0a93be075341152b623d58632fa2.tar
guix-patches-3b3b60d0370f0a93be075341152b623d58632fa2.tar.gz
gnu: Use HTTPS for all sourceforge.net home pages.
* gnu/packages/admin.scm (mingetty, clusterssh)[home-page]: Use HTTPS. * gnu/packages/audio.scm (libbs2b, soxr)[home-page]: Likewise. * gnu/packages/bioinformatics.scm (bless)[home-page]: Likewise. * gnu/packages/display-managers.scm (slim)[home-page]: Likewise. * gnu/packages/games.scm (extremetuxracer)[home-page]: Likewise. * gnu/packages/ghostscript.scm (gs-fonts)[home-page]: Likewise. * gnu/packages/haskell.scm (ghc-regex-base, ghc-regex-posix, ghc-regex-compat)[home-page]: Likewise. * gnu/packages/image.scm (imlib2)[home-page]: Likewise. * gnu/packages/libreoffice.scm (librevenge, libcmis, libodfgen, libmwaw) [home-page]: Likewise. * gnu/packages/linux.scm (hdparm, acpid, libavc1394, rng-tools) [home-page]: Likewise. * gnu/packages/mail.scm (esmtp)[home-page]: Likewise. * gnu/packages/mp3.scm (ripperx)[home-page]: Likewise. * gnu/packages/onc-rpc.scm (libtirpc)[home-page]: Likewise. * gnu/packages/perl.scm (perl-czplib)[home-page]: Likewise. * gnu/packages/python.scm (python-pyasn1-modules)[home-page]: Likewise. * gnu/packages/xdisorg.scm (xosd)[home-page]: Likewise.
-rw-r--r--gnu/packages/admin.scm4
-rw-r--r--gnu/packages/audio.scm4
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/display-managers.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/ghostscript.scm2
-rw-r--r--gnu/packages/haskell.scm6
-rw-r--r--gnu/packages/image.scm2
-rw-r--r--gnu/packages/libreoffice.scm8
-rw-r--r--gnu/packages/linux.scm8
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/mp3.scm2
-rw-r--r--gnu/packages/onc-rpc.scm2
-rw-r--r--gnu/packages/perl.scm2
-rw-r--r--gnu/packages/python.scm2
-rw-r--r--gnu/packages/xdisorg.scm2
16 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d0cded509e..8a7dc6af89 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -362,7 +362,7 @@ login, passwd, su, groupadd, and useradd.")
#:tests? #f)) ; no tests
(inputs `(("shadow" ,shadow)))
- (home-page "http://sourceforge.net/projects/mingetty")
+ (home-page "https://sourceforge.net/projects/mingetty")
(synopsis "Getty for the text console")
(description
"Small console getty that is started on the Linux text console,
@@ -717,7 +717,7 @@ by bandwidth they use.")
`("PERL5LIB" ":" prefix (,x11-inc ,tk-inc)))))
%standard-phases)))
;; The clusterssh.sourceforge.net address requires login to view
- (home-page "http://sourceforge.net/projects/clusterssh/")
+ (home-page "https://sourceforge.net/projects/clusterssh/")
(synopsis "Secure concurrent multi-server terminal control")
(description
"ClusterSSH controls a number of xterm windows via a single graphical
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 641d44cea7..2e43bafa13 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1448,7 +1448,7 @@ connections between them.")
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("libsndfile" ,libsndfile)))
- (home-page "http://sourceforge.net/projects/bs2b/")
+ (home-page "https://sourceforge.net/projects/bs2b/")
(synopsis "Bauer stereophonic-to-binaural DSP")
(description
"The Bauer stereophonic-to-binaural DSP (bs2b) library and plugins is
@@ -2279,7 +2279,7 @@ can play and record audio files.")
(base32 "1hmadwqfpg15vhwq9pa1sl5xslibrjpk6hpq2s9hfmx1s5l6ihfw"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ;no 'check' target
- (home-page "http://sourceforge.net/p/soxr/wiki/Home/")
+ (home-page "https://sourceforge.net/p/soxr/wiki/Home/")
(synopsis "One-dimensional sample-rate conversion library")
(description
"The SoX Resampler library (libsoxr) performs one-dimensional sample-rate
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 82620925a6..6b363afe0c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1097,7 +1097,7 @@ confidence to have in an alignment.")
("pigz" ,pigz)
("zlib" ,zlib)))
(supported-systems '("x86_64-linux"))
- (home-page "http://sourceforge.net/p/bless-ec/wiki/Home/")
+ (home-page "https://sourceforge.net/p/bless-ec/wiki/Home/")
(synopsis "Bloom-filter-based error correction tool for NGS reads")
(description
"@dfn{Bloom-filter-based error correction solution for high-throughput
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 0eca94550b..80b45af103 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -235,7 +235,7 @@ create smooth, animated user interfaces.")
#:tests? #f))
;; This used to be at <http://slim.berlios.de/>.
- (home-page "http://sourceforge.net/projects/slim.berlios/")
+ (home-page "https://sourceforge.net/projects/slim.berlios/")
(synopsis "Desktop-independent graphical login manager for X11")
(description
"SLiM is a Desktop-independent graphical login manager for X11, derived
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index daad696fce..c449f59549 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -968,7 +968,7 @@ Collect herrings and other goodies while sliding down the hill, but avoid fish
bones.
This game is based on the GPL version of the famous game TuxRacer.")
- (home-page "http://sourceforge.net/projects/extremetuxracer/")
+ (home-page "https://sourceforge.net/projects/extremetuxracer/")
(license license:gpl2+)))
(define-public supertuxkart
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index b254b80782..46b8c51299 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -293,7 +293,7 @@ architecture.")
"Ghostscript fonts provides fonts and font metrics customarily distributed with
Ghostscript. It currently includes the 35 standard PostScript fonts.")
(license license:gpl2)
- (home-page "http://sourceforge.net/projects/gs-fonts/")))
+ (home-page "https://sourceforge.net/projects/gs-fonts/")))
(define-public libspectre
(package
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8e5927a00b..8dd9dd41d7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2200,7 +2200,7 @@ removed. Both IPv4 and IPv6 are supported.")
(inputs
`(("ghc-mtl" ,ghc-mtl)))
(home-page
- "http://sourceforge.net/projects/lazy-regex")
+ "https://sourceforge.net/projects/lazy-regex")
(synopsis "Replaces/Enhances Text.Regex")
(description "@code{Text.Regex.Base} provides the interface API for
regex-posix, regex-pcre, regex-parsec, regex-tdfa, regex-dfa.")
@@ -2223,7 +2223,7 @@ regex-posix, regex-pcre, regex-parsec, regex-tdfa, regex-dfa.")
(build-system haskell-build-system)
(inputs
`(("ghc-regex-base" ,ghc-regex-base)))
- (home-page "http://sourceforge.net/projects/lazy-regex")
+ (home-page "https://sourceforge.net/projects/lazy-regex")
(synopsis "POSIX regular expressions for Haskell")
(description "This library provides the POSIX regex backend used by the
Haskell library @code{regex-base}.")
@@ -2247,7 +2247,7 @@ Haskell library @code{regex-base}.")
(inputs
`(("ghc-regex-base" ,ghc-regex-base)
("ghc-regex-posix" ,ghc-regex-posix)))
- (home-page "http://sourceforge.net/projects/lazy-regex")
+ (home-page "https://sourceforge.net/projects/lazy-regex")
(synopsis "Replaces/Enhances Text.Regex")
(description "This library provides one module layer over
@code{regex-posix} to replace @code{Text.Regex}.")
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3b081c12da..4e40533a21 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -580,7 +580,7 @@ compose, and analyze GIF images.")
("libtiff" ,libtiff)
("giflib" ,giflib)
("bzip2" ,bzip2)))
- (home-page "http://sourceforge.net/projects/enlightenment/")
+ (home-page "https://sourceforge.net/projects/enlightenment/")
(synopsis
"Loading, saving, rendering and manipulating image files")
(description
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 78579bbb01..79712121ea 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -144,7 +144,7 @@ CSV, CSS and XML.")
`(#:configure-flags '("--disable-werror"
;; Avoid undefined library references
"LDFLAGS=-lboost_system")))
- (home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
+ (home-page "https://sourceforge.net/p/libwpd/wiki/librevenge/")
(synopsis "Document importer for office suites")
(description "Librevenge is a base library for writing document import
filters. It has interfaces for text documents, vector graphics,
@@ -275,7 +275,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; fails without the following flag.
(string-append "--with-boost="
(assoc-ref %build-inputs "boost")))))
- (home-page "http://sourceforge.net/projects/libcmis/")
+ (home-page "https://sourceforge.net/projects/libcmis/")
(synopsis "CMIS client library")
(description "LibCMIS is a C++ client library for the CMIS interface. It
allows C++ applications to connect to any ECM behaving as a CMIS server such
@@ -561,7 +561,7 @@ Microsoft Visio documents of all versions.")
(arguments
;; avoid triggering configure errors by simple inclusion of boost headers
`(#:configure-flags '("--disable-werror")))
- (home-page "http://sourceforge.net/p/libwpd/wiki/libodfgen/")
+ (home-page "https://sourceforge.net/p/libwpd/wiki/libodfgen/")
(synopsis "ODF (Open Document Format) library")
(description "Libodfgen is a library for generating documents in the
Open Document Format (ODF). It provides generator implementations for all
@@ -592,7 +592,7 @@ text documents, vector drawings, presentations and spreadsheets.")
(arguments
;; avoid triggering configure errors by simple inclusion of boost headers
`(#:configure-flags '("--disable-werror")))
- (home-page "http://sourceforge.net/p/libmwaw/wiki/Home/")
+ (home-page "https://sourceforge.net/p/libmwaw/wiki/Home/")
(synopsis "Import library for some old Macintosh text documents")
(description "Libmwaw contains some import filters for old Macintosh
text documents (MacWrite, ClarisWorks, ... ) and for some graphics and
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0d01ece2c..0c191629ce 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2216,7 +2216,7 @@ thanks to the use of namespaces.")
"CC=gcc"))
#:phases (alist-delete 'configure %standard-phases)
#:tests? #f)) ; no test suite
- (home-page "http://sourceforge.net/projects/hdparm/")
+ (home-page "https://sourceforge.net/projects/hdparm/")
(synopsis "Tune hard disk parameters for high performance")
(description
"Get/set device parameters for Linux SATA/IDE drives. It's primary use
@@ -2282,7 +2282,7 @@ about ACPI devices.")
(base32
"1vl7c6vc724v4jwki17czgj6lnrknnj1a6llm8gkl32i2gnam5j3"))))
(build-system gnu-build-system)
- (home-page "http://sourceforge.net/projects/acpid2/")
+ (home-page "https://sourceforge.net/projects/acpid2/")
(synopsis "Daemon for delivering ACPI events to user-space programs")
(description
"acpid is designed to notify user-space programs of Advanced
@@ -2407,7 +2407,7 @@ protocol in question.")
`(("pkg-config" ,pkg-config)))
(propagated-inputs
`(("libraw1394" ,libraw1394))) ; required by libavc1394.pc
- (home-page "http://sourceforge.net/projects/libavc1394/")
+ (home-page "https://sourceforge.net/projects/libavc1394/")
(synopsis "AV/C protocol library for IEEE 1394")
(description
"Libavc1394 is a programming interface to the AV/C specification from
@@ -2888,7 +2888,7 @@ The package provides additional NTFS tools.")
(description
"Monitor a hardware random number generator, and supply entropy
from that to the system kernel's @file{/dev/random} machinery.")
- (home-page "http://sourceforge.net/projects/gkernel")
+ (home-page "https://sourceforge.net/projects/gkernel")
;; The source package is offered under the GPL2+, but the files
;; 'rngd_rdrand.c' and 'rdrand_asm.S' are only available under the GPL2.
(license (list license:gpl2 license:gpl2+))))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f198e19f29..70d9b4eee2 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1251,7 +1251,7 @@ program's primary purpose.")
("libtool" ,libtool)))
(inputs
`(("libesmtp" ,libesmtp)))
- (home-page "http://sourceforge.net/projects/esmtp/")
+ (home-page "https://sourceforge.net/projects/esmtp/")
(synopsis "Relay-only mail transfer agent (MTA)")
(description "Esmtp is a simple relay-only mail transfer agent built using
libESMTP. It sends e-mail via a remote SMTP server using credentials from the
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 057c3d72df..4f799bd200 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -392,7 +392,7 @@ Ogg, MP3, or FLAC formats. Its goal is to be easy to use, requiring only
a few mouse clicks to convert an entire album. It supports CDDB lookups
for album and track information.")
(license license:gpl2)
- (home-page "http://sourceforge.net/projects/ripperx/")))
+ (home-page "https://sourceforge.net/projects/ripperx/")))
(define-public libmpcdec
(package
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 8ef3e9f112..5353846ece 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -55,7 +55,7 @@
;; 'patch-source-shebangs' file tree traversal.
(delete-file "INSTALL"))))))
(inputs `(("mit-krb5" ,mit-krb5)))
- (home-page "http://sourceforge.net/projects/libtirpc/")
+ (home-page "https://sourceforge.net/projects/libtirpc/")
(synopsis "Transport-independent Sun/ONC RPC implementation")
(description
"This package provides a library that implements the Sun/ONC RPC (remote
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d8c217f30f..8f103ec6d7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1322,7 +1322,7 @@ Password Generator\".")
,(package-version perl)
"/czplib/"))
#t)))))
- (home-page "http://sourceforge.net/projects/czplib/")
+ (home-page "https://sourceforge.net/projects/czplib/")
(synopsis "Library for genomic analysis")
(description "Chaolin Zhang's Perl Library (czplib) contains assorted
functions and data structures for processing and analysing genomic and
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f0eb5e01fd..04cd3fa905 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6555,7 +6555,7 @@ suitable for a wide range of protocols based on the ASN.1 specification.")
(build-system python-build-system)
(propagated-inputs
`(("python-pyasn1" ,python-pyasn1)))
- (home-page "http://sourceforge.net/projects/pyasn1/")
+ (home-page "https://sourceforge.net/projects/pyasn1/")
(synopsis "ASN.1 codec implementations")
(description
"Pyasn1-modules is a collection of Python modules providing ASN.1 types and
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c7ba41bdd2..615e539e20 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -601,7 +601,7 @@ X Window System.")
("libxt" ,libxt)
("libxext" ,libxext)
("libxinerama" ,libxinerama)))
- (home-page "http://sourceforge.net/projects/libxosd/")
+ (home-page "https://sourceforge.net/projects/libxosd/")
(synopsis "X On Screen Display")
(description
"XOSD provides a C library and a simple utility (osd_cat) for displaying