summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-24 12:14:17 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-09-04 12:15:17 +0530
commit3ad6b8909025a8f4d3e1f1f5ea16bcd0cace557c (patch)
tree067e157650e98cc9ea88c847ae657400eb322788
parent9c4b522f1572db2c5dab81976982b95d5da51e6e (diff)
downloadguix-patches-3ad6b8909025a8f4d3e1f1f5ea16bcd0cace557c.tar
guix-patches-3ad6b8909025a8f4d3e1f1f5ea16bcd0cace557c.tar.gz
gnu: ghc-tasty: Update to 1.1.0.3.
* gnu/packages/haskell-check.scm (ghc-tasty): Update to 1.1.0.3. [inputs]: Add ghc-wcwidth. (ghc-attoparsec-bootstrap, ghc-integer-logarithms-bootstrap, ghc-scientific-bootstrap): New variables. (ghc-wcwidth)[inputs]: Replace ghc-attoparsec with ghc-attoparsec-bootstrap. (ghc-scientific)[inputs]: Replace ghc-integer-logarithms with ghc-integer-logarithms-bootstrap. (ghc-attoparsec)[inputs]: Replace ghc-scientific with ghc-scientific-bootstrap.
-rw-r--r--gnu/packages/haskell-check.scm7
-rw-r--r--gnu/packages/haskell.scm27
2 files changed, 28 insertions, 6 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c3ef85f3f0..1064872fec 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -183,7 +183,7 @@ timer functions of different operating systems via a unified API.")
(define-public ghc-tasty
(package
(name "ghc-tasty")
- (version "0.11.0.4")
+ (version "1.1.0.3")
(source
(origin
(method url-fetch)
@@ -193,7 +193,7 @@ timer functions of different operating systems via a unified API.")
".tar.gz"))
(sha256
(base32
- "05pxjzgbgjdn7477xry0ssjrnmnsydqiq6nm6ck8n2da1baliqp0"))))
+ "14riid753hjqr6lca1kgxpnvq0wykf0k3qc5jpag42hh8bszav22"))))
(build-system haskell-build-system)
(inputs
`(("ghc-stm" ,ghc-stm)
@@ -205,7 +205,8 @@ timer functions of different operating systems via a unified API.")
("ghc-unbounded-delays" ,ghc-unbounded-delays)
("ghc-async" ,ghc-async)
("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)))
+ ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)
+ ("ghc-wcwidth" ,ghc-wcwidth)))
(home-page "http://documentup.com/feuerbach/tasty")
(synopsis "Modern and extensible testing framework")
(description "Tasty is a modern testing framework for Haskell. It lets
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6e19cd67ee..70929ddae6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2866,7 +2866,7 @@ with slicing and Clang-style colored diagnostics.")
;; re-enable them.
(arguments `(#:tests? #f))
(inputs
- `(("ghc-scientific" ,ghc-scientific)
+ `(("ghc-scientific-bootstrap" ,ghc-scientific-bootstrap)
("ghc-text" ,ghc-text)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
@@ -2881,6 +2881,13 @@ aimed particularly at dealing efficiently with network protocols and
complicated text/binary file formats.")
(license license:bsd-3)))
+(define ghc-attoparsec-bootstrap
+ (package
+ (inherit ghc-attoparsec)
+ (name "ghc-attoparsec-bootstrap")
+ (arguments '(#:tests? #f))
+ (native-inputs '())))
+
(define-public ghc-zip-archive
(package
(name "ghc-zip-archive")
@@ -5208,6 +5215,13 @@ occurrences of a substring (the first in case of overlaps) with another.")
in migrated modules.")
(license license:expat)))
+(define ghc-integer-logarithms-bootstrap
+ (package
+ (inherit ghc-integer-logarithms)
+ (name "ghc-integer-logarithms-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs '())))
+
(define-public ghc-scientific
(package
(name "ghc-scientific")
@@ -5224,7 +5238,7 @@ in migrated modules.")
"03ql2f0ac8bsl524idy9xxa3kxisb2sj3avflzw580j5hzy0m397"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-integer-logarithms" ,ghc-integer-logarithms)
+ `(("ghc-integer-logarithms-bootstrap" ,ghc-integer-logarithms-bootstrap)
("ghc-text" ,ghc-text)
("ghc-hashable" ,ghc-hashable)
("ghc-primitive" ,ghc-primitive)))
@@ -5245,6 +5259,13 @@ and space efficient. They are represented using
notation}.")
(license license:bsd-3)))
+(define ghc-scientific-bootstrap
+ (package
+ (inherit ghc-scientific)
+ (name "ghc-scientific-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs '())))
+
(define-public ghc-boxes
(package
(name "ghc-boxes")
@@ -10168,7 +10189,7 @@ backends provided by the @code{Cairo} and @code{Diagrams} libraries.")
(inputs
`(("ghc-setlocale" ,ghc-setlocale)
("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-attoparsec" ,ghc-attoparsec)))
+ ("ghc-attoparsec-bootstrap" ,ghc-attoparsec-bootstrap)))
(home-page "https://github.com/solidsnack/wcwidth/")
(synopsis "Haskell bindings to wcwidth")
(description "This package provides Haskell bindings to your system's