summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-11 13:27:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-11 15:39:29 +0200
commit3704a7b8978d510a8bbeae0a92ed60ece808f5ac (patch)
tree4f3eb8432d98728a59ba58fe0afe9cd4aa962f10
parentfc7f80707872a35794c242da11637c4e3dab7d95 (diff)
downloadguix-patches-3704a7b8978d510a8bbeae0a92ed60ece808f5ac.tar
guix-patches-3704a7b8978d510a8bbeae0a92ed60ece808f5ac.tar.gz
gnu: Add r-tricycle.
* gnu/packages/bioconductor.scm (r-tricycle): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ce1e23f0bf..e6555c93df 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -775,6 +775,43 @@ Ensembl.")
Ensembl.")
(license license:artistic2.0)))
+(define-public r-tricycle
+ (package
+ (name "r-tricycle")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "tricycle" version))
+ (sha256
+ (base32
+ "19yh7yif8630j845m9rddva2z0xy4jcw9j4hvyr076jqbyxz998r"))))
+ (properties `((upstream-name . "tricycle")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-annotationdbi
+ r-circular
+ r-dplyr
+ r-genomicranges
+ r-ggplot2
+ r-iranges
+ r-rcolorbrewer
+ r-s4vectors
+ r-scater
+ r-scattermore
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hansenlab/tricycle")
+ (synopsis "Transferable representation and inference of cell cycle")
+ (description
+ "The package contains functions to infer and visualize cell cycle process
+using Single-cell RNA-Seq data. It exploits the idea of transfer learning,
+projecting new data to the previous learned biologically interpretable space.
+The @code{tricycle} provides a pre-learned cell cycle space, which could be
+used to infer cell cycle time of human and mouse single cell samples. In
+addition, it also offer functions to visualize cell cycle time on different
+embeddings and functions to build new reference.")
+ (license license:gpl3)))
+
(define-public r-txdb-dmelanogaster-ucsc-dm6-ensgene
(package
(name "r-txdb-dmelanogaster-ucsc-dm6-ensgene")