summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-26 22:26:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-02-26 22:26:35 +0200
commit35aa016af104567a6632abdbad72e5fd3de8e2ca (patch)
tree3a06ec9c55e4b3f46416a23b5fcec7c8eeada424
parent1094f1216f21a52453b54b43ff88b856f4fac94d (diff)
downloadguix-patches-35aa016af104567a6632abdbad72e5fd3de8e2ca.tar
guix-patches-35aa016af104567a6632abdbad72e5fd3de8e2ca.tar.gz
gnu: beignet: Limit supported architectures.
* gnu/packages/opencl.scm (beignet)[supported-systems]: New field.
-rw-r--r--gnu/packages/opencl.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index a90b17cee3..fc9c11caa5 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -289,6 +289,8 @@ Haswell, Skylake, Apollolake, etc. It defines and implements the OpenCL host
functions required to initialize the device, create the command queues, the
kernels and the programs, and run them on the GPU. The code also contains a
back-end for the LLVM compiler framework.")
+ ;; Beignet only supports Intel processors.
+ (supported-systems '("x86_64-linux" "i686-linux"))
(license license:lgpl2.1+)))
(define-public pocl