summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-29 23:36:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-30 11:53:00 +0200
commit3573e73840a59e4168cf744b86442b181b30c243 (patch)
tree5e67395383d3a1137f0a17c052afb3ce24e21a6d
parentcc142c91cf8bda1eb4de8b26b6ecfd0dbc7c9ee6 (diff)
downloadguix-patches-3573e73840a59e4168cf744b86442b181b30c243.tar
guix-patches-3573e73840a59e4168cf744b86442b181b30c243.tar.gz
gnu: net-snmp: Omit static library.
* gnu/packages/networking.scm (net-snmp)[arguments]: Add "--disable-static" configure flag.
-rw-r--r--gnu/packages/networking.scm1
-rw-r--r--gnu/packages/python.scm4
-rw-r--r--gnu/packages/xdisorg.scm4
3 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 7286e513f7..945123e600 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3214,6 +3214,7 @@ Features:
(list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib")
+ "--disable-static"
"--with-logfile=/var/log/snmpd.log"
(string-append "--with-openssl="
(assoc-ref %build-inputs "openssl")))
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ce424bdeb0..e694321e17 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -651,7 +651,7 @@ To function properly, this package should not be installed together with the
(define-public micropython
(package
(name "micropython")
- (version "1.14")
+ (version "1.15")
(source
(origin
(method url-fetch)
@@ -659,7 +659,7 @@ To function properly, this package should not be installed together with the
"releases/download/v" version
"/micropython-" version ".tar.xz"))
(sha256
- (base32 "0k6ri3rxxnnmvcbi7z7x59r21f4vj9dcf9j64jhj1cgazmb62c4p"))
+ (base32 "04sfrfcljhfps340l4wh5ffwkhw1ydraday8nv92nv7gmnrj1l2j"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bf4b062973..5573e2afb5 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1235,7 +1235,7 @@ Escape key when Left Control is pressed and released on its own.")
(define-public libwacom
(package
(name "libwacom")
- (version "1.7")
+ (version "1.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1243,7 +1243,7 @@ Escape key when Left Control is pressed and released on its own.")
"libwacom-" version "/libwacom-" version ".tar.bz2"))
(sha256
(base32
- "0797gc055dgg2jfqijy9823bd83jwr4wb2z9id992qlcr0xmz1rw"))))
+ "14aj4ss1chxxgaprs9sfriia2ch9wj9rqay0ndkzk1m7jx2qrjgn"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags '("--disable-static")))