summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid <navid.afkhami@mdc-berlin.de>2022-04-27 16:40:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-29 18:14:37 +0200
commit325d53d5f634f6490e3291304fb5522400039224 (patch)
tree35e4591d02b1619c92713440a94669341a006b61
parentc1719a0adf3fa7611b56ca4d75b3ac8cf5c9c8ac (diff)
downloadguix-patches-325d53d5f634f6490e3291304fb5522400039224.tar
guix-patches-325d53d5f634f6490e3291304fb5522400039224.tar.gz
gnu: Add r-afpt.
* gnu/packages/cran.scm (r-afpt): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1609682b8d..a673efcf73 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,6 +113,30 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public r-afpt
+ (package
+ (name "r-afpt")
+ (version "1.1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "afpt" version))
+ (sha256
+ (base32
+ "0cg5cdm9nl1hs6f3j0ljpw4bkqvh3ksyj615b9nnbqs5k28lyds9"))))
+ (properties `((upstream-name . "afpt")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/MarcoKlH/afpt-r/")
+ (synopsis "Tools for modelling of animal flight performance")
+ (description
+ "This package allows estimation and modelling of flight costs in animal
+(vertebrate) flight, implementing the aerodynamic power model. Flight
+performance is estimated based on basic morphological measurements such as
+body mass, wingspan and wing area. @code{Afpt} can be used to make
+predictions on how animals should adjust their flight behaviour and wingbeat
+kinematics to varying flight conditions.")
+ (license license:gpl3+)))
+
(define-public r-aod
(package
(name "r-aod")