summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-07 09:44:10 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-07 16:48:50 +0100
commit3246cc91858a18344a6b62272521c88dd0ec5037 (patch)
treeb839dc4d8cc70c29a481271790c2d4ddd584066d
parentc154e1ea81b1eb81c5716ce5a4df694fbd05c421 (diff)
downloadguix-patches-3246cc91858a18344a6b62272521c88dd0ec5037.tar
guix-patches-3246cc91858a18344a6b62272521c88dd0ec5037.tar.gz
gnu: Make libtool and libltdl completely separate.
* gnu/packages/autotools.scm (libtool)[outputs]: Remove. [arguments]: Remove 'if' around arguments. Add #:configure-flags. * gnu/packages/apr.scm (apr)[inputs]: Change libtool to libltdl. * gnu/packages/fontutils.scm (libuninameslist)[native-inputs]: Remove "libtool-bin". * gnu/packages/global.scm (global): Change libtool to libltdl. * gnu/packages/gnunet.scm (libextractor, gnunet): Likewise. * gnu/packages/graphviz.scm (graphviz): Likewise. * gnu/packages/libcanberra.scm (libcanberra): Likewise. * gnu/packages/libevent.scm (libuv)[native-inputs]: Remove "bin" part for libtool. * gnu/packages/mail.scm (mailutils): Change libtool to libltdl. (libetpan): Remove "bin" part for libtool. * gnu/packages/mp3.scm (libmp3splt): Change libtool to libltdl. * gnu/packages/openldap.scm (openldap): Remove "bin" part of libtool. Move it from 'inputs' to 'native-inputs'. * gnu/packages/photo.scm (libgphoto2): Change libtool to libltdl. * gnu/packages/pulseaudio.scm (pulseaudio): Likewise. * gnu/packages/ssh.scm (guile-ssh): Remove "bin" part of libtool. * gnu/packages/web.scm (libpsl): Likewise. * gnu/packages/weechat.scm (weechat): Move libtool to 'native-inputs' and add libltdl to 'inputs'.
-rw-r--r--gnu/packages/apr.scm2
-rw-r--r--gnu/packages/autotools.scm49
-rw-r--r--gnu/packages/fontutils.scm3
-rw-r--r--gnu/packages/global.scm4
-rw-r--r--gnu/packages/gnunet.scm4
-rw-r--r--gnu/packages/graphviz.scm4
-rw-r--r--gnu/packages/libcanberra.scm4
-rw-r--r--gnu/packages/libevent.scm4
-rw-r--r--gnu/packages/mail.scm6
-rw-r--r--gnu/packages/mp3.scm4
-rw-r--r--gnu/packages/openldap.scm4
-rw-r--r--gnu/packages/photo.scm4
-rw-r--r--gnu/packages/pulseaudio.scm6
-rw-r--r--gnu/packages/ssh.scm2
-rw-r--r--gnu/packages/web.scm5
-rw-r--r--gnu/packages/weechat.scm6
16 files changed, 52 insertions, 59 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index cedeea8a14..3e53a614fc 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -48,7 +48,7 @@
'(#:parallel-build? #f
#:parallel-tests? #f))
(inputs `(("perl" ,perl)
- ("libtool" ,libtool)))
+ ("libltdl" ,libltdl)))
(home-page "http://apr.apache.org/")
(synopsis "The Apache Portable Runtime Library")
(description
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 0ee1d149b9..07fdde73ea 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -254,36 +254,31 @@ Makefile, simplifying the entire process for the developer.")
("automake" ,automake) ;some tests rely on 'aclocal'
("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
- ;; Separate binaries from the rest. During bootstrap, only ltdl is
- ;; used; not depending on the binaries allows us to avoid retaining
- ;; a reference to the bootstrap bash.
- (outputs '("bin" ;libtoolize, libtool, etc.
- "out")) ;libltdl.so, ltdl.h, etc.
-
(arguments
- (if (%current-target-system)
- '() ;no `check' phase when cross-building
- `(;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
- ;; <http://hydra.gnu.org/build/181662>.
- #:tests? ,(not (string-prefix? "mips64"
- (or (%current-target-system)
- (%current-system))))
+ `(;; Libltdl is provided as a separate package, so don't install it here.
+ #:configure-flags '("--disable-ltdl-install")
+
+ ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
+ ;; <http://hydra.gnu.org/build/181662>.
+ #:tests? ,(not (string-prefix? "mips64"
+ (or (%current-target-system)
+ (%current-system))))
- #:phases (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Run the test suite in parallel, if possible.
- (setenv "TESTSUITEFLAGS"
- (string-append
- "-j"
- (number->string (parallel-job-count))))
+ #:phases (alist-cons-before
+ 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Run the test suite in parallel, if possible.
+ (setenv "TESTSUITEFLAGS"
+ (string-append
+ "-j"
+ (number->string (parallel-job-count))))
- ;; Path references to /bin/sh.
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "tests/testsuite"
- (("/bin/sh")
- (string-append bash "/bin/bash")))))
- %standard-phases))))
+ ;; Path references to /bin/sh.
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "tests/testsuite"
+ (("/bin/sh")
+ (string-append bash "/bin/bash")))))
+ %standard-phases)))
(synopsis "Generic shared library support tools")
(description
"GNU Libtool helps in the creation and use of shared libraries, by
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index a4da6df553..f98625cdae 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -272,8 +272,7 @@ smooth contours with constant curvature at the spline joins.")
(build-system gnu-build-system)
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
- ("libtool" ,libtool)
- ("libtool-bin" ,libtool "bin")))
+ ("libtool" ,libtool)))
(arguments
`(#:phases (alist-cons-before
'configure 'bootstrap
diff --git a/gnu/packages/global.scm b/gnu/packages/global.scm
index f7377def0a..72a53ad4a8 100644
--- a/gnu/packages/global.scm
+++ b/gnu/packages/global.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,7 +38,7 @@
"0j828dg2cjf77rx71cw68jpk7jl119v6nyb0kyvirr5i1860j1fx"))))
(build-system gnu-build-system)
(inputs `(("ncurses" ,ncurses)
- ("libtool" ,libtool)))
+ ("libltdl" ,libltdl)))
(arguments
`(#:configure-flags
(list (string-append "--with-ncurses="
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 249971becd..f7063ead11 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -85,7 +85,7 @@
("libjpeg" ,libjpeg)
("libogg" ,libogg)
("libtiff" ,libtiff)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("libvorbis" ,libvorbis)
("zlib" ,zlib)))
(native-inputs
@@ -213,7 +213,7 @@ supports HTTPS, HTTPS and GnuTLS.")
("libgcrypt" ,libgcrypt)
("libidn" ,libidn)
("libmicrohttpd" ,libmicrohttpd)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("libunistring" ,libunistring)
("openssl" ,openssl)
("opus" ,opus)
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index dc477f30b3..52522af446 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,7 +69,7 @@
("pango" ,pango)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
- ("libltdl" ,libtool)
+ ("libltdl" ,libltdl)
("libXaw" ,libxaw)
("expat" ,expat)
("libjpeg" ,libjpeg)
diff --git a/gnu/packages/libcanberra.scm b/gnu/packages/libcanberra.scm
index 764c3272a2..859740aaee 100644
--- a/gnu/packages/libcanberra.scm
+++ b/gnu/packages/libcanberra.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,7 +52,7 @@
`(("alsa-lib" ,alsa-lib)
("gstreamer" ,gstreamer)
("gtk+" ,gtk+)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("libvorbis" ,libvorbis)
("pulseaudio" ,pulseaudio)
("udev" ,eudev)))
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 27416a0e59..64892bf878 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -85,7 +85,7 @@ loop.")
#:tests? #f))
(native-inputs `(("autoconf" ,(autoconf-wrapper))
("automake" ,automake)
- ("libtool" ,libtool "bin")
+ ("libtool" ,libtool)
;; libuv.pc is installed only when pkg-config is found.
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8424d8ccbe..62f86ef839 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
@@ -113,7 +113,7 @@
("readline" ,readline-6.2)
("linux-pam" ,linux-pam)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("gdbm" ,gdbm)))
(home-page "http://www.gnu.org/software/mailutils/")
(synopsis "Utilities and library for reading and serving mail")
@@ -419,7 +419,7 @@ useful features.")
(build-system gnu-build-system)
(native-inputs `(("autoconf" ,(autoconf-wrapper))
("automake" ,automake)
- ("libtool" ,libtool "bin")
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(propagated-inputs
;; 'libetpan-config --libs' returns '-lssl -lcrypto -lsasl2', so these
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 1731cd59af..55ab4b497c 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -231,7 +231,7 @@ pre-defined or user-specifiable output format.")
(inputs `(("libid3tag" ,libid3tag)
("libmad" ,libmad)
("libogg" ,libogg)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("libvorbid" ,libvorbis)
("pcre" ,pcre)))
(native-inputs
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 23c32488e9..a6c4cb0d93 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
@@ -52,8 +52,8 @@
;; FIXME: currently, openldap requires openssl or gnutls<3, see
;; http://www.openldap.org/its/index.cgi/Incoming?id=7430;page=17
;; Once this is fixed, switch to gnutls.
- ("libtool" ,libtool "bin")
("zlib" ,zlib)))
+ (native-inputs `(("libtool" ,libtool)))
(arguments
`(#:tests? #f
#:phases
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 4f1787fe75..164f6e27ea 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,7 +64,7 @@ data as produced by digital cameras.")
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(;; ("libjpeg-turbo" ,libjpeg-turbo)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("libusb" ,libusb)))
(propagated-inputs
`(;; The .pc refers to libexif.
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 61e0d029f5..1e9fe41b47 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -24,7 +24,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
- #:use-module ((gnu packages autotools) #:select (libtool))
+ #:use-module ((gnu packages autotools) #:select (libltdl))
#:use-module (gnu packages avahi)
#:use-module (gnu packages check)
#:use-module (gnu packages gdbm)
@@ -157,7 +157,7 @@ rates. ")
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("m4" ,m4)
- ("libtool" ,libtool)
+ ("libltdl" ,libltdl)
("fftwf" ,fftwf)
("avahi" ,avahi)
("check" ,check)))
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index c39d5f82be..79e8077cdf 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -226,7 +226,7 @@ Additionally, various channel-specific options can be negotiated.")
#:parallel-tests? #f))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
- ("libtool" ,libtool "bin")
+ ("libtool" ,libtool)
("texinfo" ,texinfo)
("pkg-config" ,pkg-config)
("which" ,which)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8a64211697..554f2a3ae4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -231,8 +231,7 @@ for efficient socket-like bidirectional reliable communication channels.")
("automake" ,automake)
("gettext" ,gnu-gettext)
("which" ,which)
- ("libtool" ,libtool)
- ("libtool" ,libtool "bin")))
+ ("libtool" ,libtool)))
(arguments
`(#:phases (alist-cons-before
'bootstrap 'fix-autogen-shebang
diff --git a/gnu/packages/weechat.scm b/gnu/packages/weechat.scm
index 5555601d47..a2e53481c3 100644
--- a/gnu/packages/weechat.scm
+++ b/gnu/packages/weechat.scm
@@ -58,12 +58,12 @@
("pkg-config" ,pkg-config)
("file" ,file)
("autogen" ,autogen)
- ("automake" ,automake)))
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(inputs `(("ncurses" ,ncurses)
("diffutils" ,diffutils)
("gettext" ,gnu-gettext)
- ("libtool" ,libtool "bin")
- ("libtool" ,libtool "out")
+ ("libltdl" ,libltdl)
("libgcrypt" ,libgcrypt "out")
("zlib" ,zlib)
("aspell" ,aspell)