summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-08-23 23:21:17 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-25 08:50:02 +0800
commit31339f5f5ffd80f3fca9dbe49990fa3be4234bb5 (patch)
tree60d0441806c5375044b839871aa7270e28c026cc
parenta39207f7afd977e4e4299c6f0bb34bcb6d153818 (diff)
downloadguix-patches-31339f5f5ffd80f3fca9dbe49990fa3be4234bb5.tar
guix-patches-31339f5f5ffd80f3fca9dbe49990fa3be4234bb5.tar.gz
gnu: Rename procedure "qt5-urls" to "qt-urls" in (gnu packages qt).
This procedure now used by Qt5 and Qt6. "qt-urls" is more neutral than original one. * gnu/packages/qt.scm (qt5-urls): Rename to "qt-urls". (qtbase-5)[source]: Use "qt-urls" for uri field. (qtbase)[source]: Ditto. (qt5compat)[source]: Ditto. (qtsvg-5)[source]: Ditto. (qtsvg)[source]: Ditto. (qtimageformats)[source]: Ditto. (qtx11extras)[source]: Ditto. (qtxmlpatterns)[source]: Ditto. (qtdeclarative-5)[source]: Ditto. (qtdeclarative)[source]: Ditto. (qtconnectivity)[source]: Ditto. (qtwebsockets-5)[source]: Ditto. (qtwebsockets)[source]: Ditto. (qtsensors)[source]: Ditto. (qtmultimedia-5)[source]: Ditto. (qtshadertools)[source]: Ditto. (qtmultimedia)[source]: Ditto. (qtwayland)[source]: Ditto. (qtserialport)[source]: Ditto. (qtserialbus)[source]: Ditto. (qtwebchannel-5)[source]: Ditto. (qtwebchannel)[source]: Ditto. (qtwebglplugin)[source]: Ditto. (qtwebview)[source]: Ditto. (qtlottie)[source]: Ditto. (qttools-5)[source]: Ditto. (qttools)[source]: Ditto. (qtscript)[source]: Ditto. (qtquickcontrols-5)[source]: Ditto. (qtquickcontrols2-5)[source]: Ditto. (qtgraphicaleffects)[source]: Ditto. (qtgamepad)[source]: Ditto. (qtscxml)[source]: Ditto. (qtpositioning)[source]: Ditto. (qtpurchasing)[source]: Ditto. (qtcharts)[source]: Ditto. (qtdatavis3d)[source]: Ditto. (qtnetworkauth-5)[source]: Ditto. (qtnetworkauth)[source]: Ditto. (qtremoteobjects)[source]: Ditto. (qtspeech)[source]: Ditto. (qtwebengine-5)[source]: Ditto. (qtwebengine)[source]: Ditto. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/qt.scm88
1 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d9d796f551..9832568d10 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -262,7 +262,7 @@ other text such as code. The syntax uses the syntax of the Django template
system, and the core design of Django is reused in Grantlee.")
(license license:lgpl2.1+)))
-(define (qt5-urls component version)
+(define (qt-urls component version)
"Return a list of URLs for VERSION of the Qt5 COMPONENT."
;; We can't use a mirror:// scheme because these URLs are not exact copies:
;; the layout differs between them.
@@ -286,7 +286,7 @@ system, and the core design of Django is reused in Grantlee.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1y70libf2x52lpbqvhz10lpk7nyl1ajjwzjxly9pjdpfj4jsv7wh"))
@@ -540,7 +540,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(version "6.3.1")
(source (origin
(inherit (package-source qtbase-5))
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"00sfya41ihqb0zwg6wf1kiy02iymj6mk584hhk2c4s94khfl4r0a"))
@@ -822,7 +822,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1zbcaswpl79ixcxzj85qzjq73962s4c7316pibwfrskqswmwcgm4"))))
@@ -852,7 +852,7 @@ came with the @{qtgraphicaleffects} Qt 5 package.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0pjqrdmd1991x9h4rl8sf81pkd89hfd5h1a2gp3fjw96pk0w5hwb"))))
@@ -922,7 +922,7 @@ HostData=lib/qt5
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1xvxz2jfpr1al85rhwss7ji5vkxa812d0b888hry5f7pwqcg86bv"))))
@@ -953,7 +953,7 @@ HostData=lib/qt5
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1msk8a0z8rr16hkp2fnv668vf6wayiydqgc2mcklaa04rv3qb0mz"))
@@ -991,7 +991,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0gkfzj195v9flwljnqpdz3a532618yn4h2577nlsai56x4p7053h"))))
@@ -1011,7 +1011,7 @@ from within Qt 5.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1ypj5jpa31rlx8yfw3y9jia212lfnxvnqkvygs6ihjf3lxi23skn"))))
@@ -1038,7 +1038,7 @@ xmlpatternsvalidator.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0lancdn7y0lrlmyn5cbdm0izd5yprvd5n77nhkb7a3wl2sbx0066"))))
@@ -1079,7 +1079,7 @@ with JavaScript and C++.")))
;; TODO: Package 'masm' and unbundle from sources.
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1s268fha3650dn1lqxf8jfa07wxpw09f6p7rjyiwq3w24d0nkrq3"))))
@@ -1206,7 +1206,7 @@ integrate QML code with JavaScript and C++.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"185zci61ip1wpjrygcw2m6v55lvninc0b8y2p3jh6qgpf5w35003"))))
@@ -1224,7 +1224,7 @@ with Bluetooth and NFC.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0gr399fn5n8j3m9d3vv01vcbr1cb7pw043j04cnnxzrlvn2jvd50"))))
@@ -1247,7 +1247,7 @@ consume data received from the server, or both.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"06hj0pkdzjicmbiinjp1dk1ziz8cb3fgcwy7a0dxxjvzr680v64z"))))
@@ -1286,7 +1286,7 @@ consume data received from the server, or both.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0fa81r7bn1mf9ynwsx524a55dx1q0jb4vda6j48ssb4lx7wi201z"))))
@@ -1316,7 +1316,7 @@ recognition API for devices.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1xbd6kc7i0iablqdkvfrajpi32cbq7j6ajbfyyyalcai1s0mhdqc"))
@@ -1361,7 +1361,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
;; Note: the source bundles *patched* glslang and SPIRV-Cross
;; sources.
(sha256
@@ -1390,7 +1390,7 @@ Vulkan, OpenGL and other main graphic APIs.")
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0dkk3lmzi2fs13cnj8q1lpcs6gghj219826gkwnzyd6nmlm280vy"))
@@ -1455,7 +1455,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(patches (search-patches "qtwayland-gcc-11.patch"))
(sha256
(base32
@@ -1505,7 +1505,7 @@ compositor libraries.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"17gp5qzg4wdg8qlxk2p3mh8x1vk33rf33wic3fy0cws193bmkiar"))))
@@ -1535,7 +1535,7 @@ interacting with serial ports from within Qt.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"125x6756fjpldqy6wbw6cg7ngjh2016aiq92bchh719z1mf7xsxf"))))
@@ -1565,7 +1565,7 @@ and others.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1h9y634phvvk557mhmf9z4lmxr41rl8x9mqy2lzp31mk8ffffzqj"))))
@@ -1584,7 +1584,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0s16zx3qn3byldvhmsnwijm8rmizk8vpqj7fnwhjg6c67z10m8ma"))))
@@ -1621,7 +1621,7 @@ application).")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0ihlnhv8ldkqz82v3j7j22lrhk17b6ghra8sx85y2agd2ysq5rw1"))))
@@ -1650,7 +1650,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1rw1wibmbxlj6xc86qs3y8h42al1vczqiksyxzaylxs9gqb4d7xy"))))
@@ -1693,7 +1693,7 @@ positioning and geolocation plugins.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1x8wmc6gwmxk92zjcsrbhrbqbfvnk7302ggghld5wk8jk5lsf2vl"))))
@@ -1725,7 +1725,7 @@ plugin for Adobe After Effects.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1k618f7v6jaj0ygy8d7jvgb8zjr47sn55kiskbdkkizp3z7d12f1"))))
@@ -1747,7 +1747,7 @@ that helps in Qt development.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1h96w4bzkbd80vr7lh6hnypdlmbzc1y52c2zrqzvkgm3587pa4n4"))))
@@ -1774,7 +1774,7 @@ that helps in Qt development.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0gk74hk488k9ldacxbxcranr3arf8ifqg8kz9nm1rgdgd59p36d2"))
@@ -1794,7 +1794,7 @@ ECMAScript and Qt.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1dczakl868mg0lnwpf082jjc5976ycn879li1vqlgw5ihirzp4y3"))))
@@ -1814,7 +1814,7 @@ can be used to build complete interfaces in Qt Quick.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"06c9vrwvbjmzapmfa25y34lgjkzg57xxbm92nr6wkv5qykjnq6v7"))))
@@ -1841,7 +1841,7 @@ not available.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1r6zfc0qga2ax155js7c8y5rx6vgayf582s921j09mb797v6g3gc"))))
@@ -1864,7 +1864,7 @@ coloring, and many more.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0p07bg93fdfn4gr2kv38qgnws5znhswajrxdfs8xc9l3i7vi2xn7"))))
@@ -1890,7 +1890,7 @@ and mobile applications targeting TV-like form factors.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1p5771b9hnpchfcdgy0zkhwg09a6xq88934aggp0rij1k85mkfb0"))
@@ -1917,7 +1917,7 @@ also contains functionality to support data models and executable content.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0v78wamvdw02kf9rq7m5v24q2g6jmgq4ch0fnfa014p1r978wy06"))))
@@ -1947,7 +1947,7 @@ information and perform area based monitoring.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"09rjx53519dfk4qj2gbn3vlxyriasyb747wpg1p11y7jkwqhs4l7"))))
@@ -1963,7 +1963,7 @@ purchasing goods and services.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"049x7z8zcp9jixmdv2fjscy2ggpd6za9hkdbb2bqp2mxjm0hwxg0"))))
@@ -1986,7 +1986,7 @@ selecting one of the charts themes.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1zdn3vm0nfy9ny7c783aabp3mhlnqhi9fw2rljn7ibbksmsnasi2"))))
@@ -2009,7 +2009,7 @@ customized by using themes or by adding custom items and labels to them.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"11fdgacv4syr8bff2vdw7rb0dg1gcqpdf37hm3pn31d6z91frhpw"))))
@@ -2035,7 +2035,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(version "6.3.1")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0apvsb2ip1m3kw8vi9spvf6f6q72ys8vr40rpyysi7shsjwm83yn"))))
@@ -2055,7 +2055,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1hngbp0vkr35rpsrac7b9vx6f360v8v2g0fffzm590l8j2ybd0b7"))))
@@ -2088,7 +2088,7 @@ processes or computers.")))
(version "5.15.2")
(source (origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1xc3x3ghnhgchsg1kgj156yg69wn4rwjx8r28i1jd05hxjggn468"))))
@@ -2145,7 +2145,7 @@ using the Enchant spell-checking library.")
(source
(origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"1q4idxdm81sx102xc12ixj0xpfx52d6vwvs3jpapnkyq8c7cmby8"))
@@ -2509,7 +2509,7 @@ and binaries removed, and adds modular support for using system libraries.")
(source
(origin
(method url-fetch)
- (uri (qt5-urls name version))
+ (uri (qt-urls name version))
(sha256
(base32
"0ivfsqd5c0cxsnssj6z37901cf6a47w50zaqgjiysvcm3ar36ymd"))