summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-14 15:49:36 -0400
committerLeo Famulari <leo@famulari.name>2017-03-14 18:26:28 -0400
commit2eab5db300b729b5e5cab95a8c39c3e4e0153b37 (patch)
tree637ffd25339d81197e0102e5a3c6331841190b7f
parent850edd77f92c1f40a1593f3505ff82fdd8719bad (diff)
downloadguix-patches-2eab5db300b729b5e5cab95a8c39c3e4e0153b37.tar
guix-patches-2eab5db300b729b5e5cab95a8c39c3e4e0153b37.tar.gz
Revert "gnu: gitolite: Fix shebangs in hooks."
This change embedded store references in the shebangs of scripts that were meant to be copied out of the store. Those scripts would break when the interpreters expected by the shebangs were garbage collected. <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25966#28> This reverts commit d0c16adb190c7244ee3ef1329cba78a015ae5d10.
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ccda00173d..1076c18905 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -616,17 +616,6 @@ also walk each side of a merge and test those changes individually.")
(substitute* (find-files "." ".*")
((" perl -")
(string-append " " perl " -"))))))
- (add-before 'install 'fix-hooks-shebangs
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((perl (string-append (assoc-ref inputs "perl")
- "/bin/perl")))
- ;; The files in 'lib/Gitolite/Hooks' keep references to
- ;; '/usr/bin/perl', without this fix it is impossible to
- ;; to run gitolite in production.
- (substitute* (find-files "src/lib/Gitolite/Hooks" ".*")
- (("/usr/bin/perl")
- perl))
- #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((output (assoc-ref outputs "out"))