summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-02-19 22:37:02 +0100
committerAndreas Enge <andreas@enge.fr>2019-02-19 22:37:02 +0100
commit2e125ece093ef842ca017ffb146cbc5fa33f2f75 (patch)
tree859ba5072c5caf86c6ca1b6450f242108c759cf8
parentc12b23469576fb1c3920120ef06b696daa30b855 (diff)
downloadguix-patches-2e125ece093ef842ca017ffb146cbc5fa33f2f75.tar
guix-patches-2e125ece093ef842ca017ffb146cbc5fa33f2f75.tar.gz
gnu: pplacer: Remove the package, which is affected by a CVE on ocaml@4.01.
This makes progress towards fixing <https://bugs.gnu.org/27462>. * gnu/packages/bioinformatics.scm (pplacer, pplacer-scripts): Remove variables.
-rw-r--r--gnu/packages/bioinformatics.scm124
1 files changed, 0 insertions, 124 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 69c85563e1..5dc3945035 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4365,130 +4365,6 @@ interrupted by stop codons. OrfM finds and prints these ORFs.")
(home-page "https://github.com/wwood/OrfM")
(license license:lgpl3+)))
-(define-public pplacer
- (let ((commit "807f6f3"))
- (package
- (name "pplacer")
- ;; The commit should be updated with each version change.
- (version "1.1.alpha19")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/matsen/pplacer.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "11ppbbbx20p2g9wj3ff64dhnarb12q79v7qh4rk0gj6lkbz4n7cn"))))
- (build-system ocaml-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.01
- #:findlib ,ocaml4.01-findlib
- #:modules ((guix build ocaml-build-system)
- (guix build utils)
- (ice-9 ftw))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'replace-bundled-cddlib
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((cddlib-src (assoc-ref inputs "cddlib-src"))
- (local-dir "cddlib_guix"))
- (mkdir local-dir)
- (with-directory-excursion local-dir
- (invoke "tar" "xvf" cddlib-src))
- (let ((cddlib-src-folder
- (string-append local-dir "/"
- (list-ref (scandir local-dir) 2)
- "/lib-src")))
- (for-each make-file-writable (find-files "cdd_src" ".*"))
- (for-each
- (lambda (file)
- (copy-file file
- (string-append "cdd_src/" (basename file))))
- (find-files cddlib-src-folder ".*[ch]$")))
- #t)))
- (add-after 'unpack 'fix-makefile
- (lambda _
- ;; Remove system calls to 'git'.
- (substitute* "Makefile"
- (("^DESCRIPT:=pplacer-.*")
- (string-append
- "DESCRIPT:=pplacer-$(shell uname)-v" ,version "\n")))
- (substitute* "myocamlbuild.ml"
- (("git describe --tags --long .*\\\" with")
- (string-append
- "echo -n v" ,version "-" ,commit "\" with")))
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (copy-recursively "bin" bin))
- #t)))))
- (native-inputs
- `(("zlib" ,zlib)
- ("gsl" ,gsl)
- ("ocaml-ounit" ,ocaml4.01-ounit)
- ("ocaml-batteries" ,ocaml4.01-batteries)
- ("ocaml-camlzip" ,ocaml4.01-camlzip)
- ("ocaml-csv" ,ocaml4.01-csv)
- ("ocaml-sqlite3" ,ocaml4.01-sqlite3)
- ("ocaml-xmlm" ,ocaml4.01-xmlm)
- ("ocaml-mcl" ,ocaml4.01-mcl)
- ("ocaml-gsl" ,ocaml4.01-gsl)
- ("cddlib-src" ,(package-source cddlib))))
- (propagated-inputs
- `(("pplacer-scripts" ,pplacer-scripts)))
- (synopsis "Phylogenetic placement of biological sequences")
- (description
- "Pplacer places query sequences on a fixed reference phylogenetic tree
-to maximize phylogenetic likelihood or posterior probability according to a
-reference alignment. Pplacer is designed to be fast, to give useful
-information about uncertainty, and to offer advanced visualization and
-downstream analysis.")
- (home-page "http://matsen.fhcrc.org/pplacer")
- (license license:gpl3))))
-
-;; This package is installed alongside 'pplacer'. It is a separate package so
-;; that it can use the python-build-system for the scripts that are
-;; distributed alongside the main OCaml binaries.
-(define pplacer-scripts
- (package
- (inherit pplacer)
- (name "pplacer-scripts")
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'enter-scripts-dir
- (lambda _ (chdir "scripts") #t))
- (replace 'check
- (lambda _ (invoke "python" "-m" "unittest" "discover" "-v") #t))
- (add-after 'install 'wrap-executables
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (let ((path (string-append
- (assoc-ref inputs "hmmer") "/bin:"
- (assoc-ref inputs "infernal") "/bin")))
- (display path)
- (wrap-program (string-append bin "/refpkg_align.py")
- `("PATH" ":" prefix (,path))))
- (let ((path (string-append
- (assoc-ref inputs "hmmer") "/bin")))
- (wrap-program (string-append bin "/hrefpkg_query.py")
- `("PATH" ":" prefix (,path)))))
- #t)))))
- (inputs
- `(("infernal" ,infernal)
- ("hmmer" ,hmmer)))
- (propagated-inputs
- `(("python-biopython" ,python2-biopython)
- ("taxtastic" ,taxtastic)))
- (synopsis "Pplacer Python scripts")))
-
(define-public python2-pbcore
(package
(name "python2-pbcore")