summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-06 20:50:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-06 21:54:04 +0300
commit2de4d6215efa09930e66172799e50992b49bebbe (patch)
tree41b25c1ab5d8b6173423b74fa902c90e137aae29
parent4586b7620a6a8c4061b1dea812794892dc9c8616 (diff)
downloadguix-patches-2de4d6215efa09930e66172799e50992b49bebbe.tar
guix-patches-2de4d6215efa09930e66172799e50992b49bebbe.tar.gz
gnu: Add rust-pango-0.8.
* gnu/packages/crates-io.scm (rust-pango-0.8): New variable. (rust-pango-0.7): Inherit from rust-pango-0.8.
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 31 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cba0adaf48..15266c416b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -15446,10 +15446,10 @@ normally prevent moving a type that has been borrowed from.")
"Automatically implement traits from the palette crate.")
(license (list license:expat license:asl2.0))))
-(define-public rust-pango-0.7
+(define-public rust-pango-0.8
(package
(name "rust-pango")
- (version "0.7.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
@@ -15458,12 +15458,12 @@ normally prevent moving a type that has been borrowed from.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "11np7nxb69g3kid2l78b7k519x1wk1c3f9yy7swgzy24n5qs0grr"))))
+ "0xq50950il3228grzs4xvc5s6phxcl5l50grz6syvs0vixr6p70y"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-bitflags" ,rust-bitflags-1)
- ("rust-glib" ,rust-glib-0.8)
+ ("rust-glib" ,rust-glib-0.9)
("rust-glib-sys" ,rust-glib-sys-0.9)
("rust-gobject-sys" ,rust-gobject-sys-0.9)
("rust-lazy-static" ,rust-lazy-static-1)
@@ -15480,6 +15480,33 @@ normally prevent moving a type that has been borrowed from.")
"Rust bindings for the Pango library.")
(license license:expat)))
+(define-public rust-pango-0.7
+ (package
+ (inherit rust-pango-0.8)
+ (name "rust-pango")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pango" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11np7nxb69g3kid2l78b7k519x1wk1c3f9yy7swgzy24n5qs0grr"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-glib" ,rust-glib-0.8)
+ ("rust-glib-sys" ,rust-glib-sys-0.9)
+ ("rust-gobject-sys" ,rust-gobject-sys-0.9)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-pango-sys" ,rust-pango-sys-0.9)
+ ("rust-gtk-rs-lgpl-docs" ,rust-gtk-rs-lgpl-docs-0.1))
+ #:cargo-development-inputs
+ (("rust-gir-format-check" ,rust-gir-format-check-0.1))))))
+
(define-public rust-pango-sys-0.9
(package
(name "rust-pango-sys")