summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-14 15:47:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:11 +0100
commit2c560aa217284c3152378e5c79f0519d78cba226 (patch)
tree15b35e255499e17101df5e0ad044a32a85a45d2f
parent16144199c3689def649ec65a45766a7d5862e868 (diff)
downloadguix-patches-2c560aa217284c3152378e5c79f0519d78cba226.tar
guix-patches-2c560aa217284c3152378e5c79f0519d78cba226.tar.gz
gnu: perl-www-curl: Fix build with curl@7.69.1.
* gnu/packages/web.scm (perl-www-curl)[source]: Add perl-www-curl-fix-struct-void.patch. * gnu/packages/patches/perl-www-curl-remove-symbol.patch: Update. * gnu/packages/patches/perl-www-curl-fix-struct-void.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/perl-www-curl-fix-struct-void.patch24
-rw-r--r--gnu/packages/patches/perl-www-curl-remove-symbol.patchbin1177 -> 984 bytes
-rw-r--r--gnu/packages/web.scm4
4 files changed, 27 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b5f9c56324..6a0f378bb0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1450,6 +1450,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-text-markdown-discount-unbundle.patch \
%D%/packages/patches/perl-module-pluggable-search.patch \
%D%/packages/patches/perl-reproducible-build-date.patch \
+ %D%/packages/patches/perl-www-curl-fix-struct-void.patch \
%D%/packages/patches/perl-www-curl-remove-symbol.patch \
%D%/packages/patches/picard-fix-id3-rename-test.patch \
%D%/packages/patches/picprog-non-intel-support.patch \
diff --git a/gnu/packages/patches/perl-www-curl-fix-struct-void.patch b/gnu/packages/patches/perl-www-curl-fix-struct-void.patch
new file mode 100644
index 0000000000..b150950668
--- /dev/null
+++ b/gnu/packages/patches/perl-www-curl-fix-struct-void.patch
@@ -0,0 +1,24 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sat, 14 Nov 2020 15:40:56 +0100
+Subject: [PATCH] gnu: perl-www-curl: Fix struct void* usage.
+
+Copied verbatim from Gentoo[0]. Fixes:
+
+ Curl.xs:76:12: error: expected ‘{’ before ‘void’
+ struct void *curlm;
+ ^~~~
+ Curl.xs:76:12: error: two or more data types in declaration specifiers
+
+[0]: https://694466.bugs.gentoo.org/attachment.cgi?id=595098
+
+--- WWW-Curl-4.17/Curl.xs 2014-02-21 18:08:30.000000000 +0200
++++ WWW-Curl-4.17.new/Curl.xs 2019-11-05 21:44:55.434395739 +0200
+@@ -73,7 +73,7 @@ typedef struct {
+ #ifdef __CURL_MULTI_H
+ struct CURLM *curlm;
+ #else
+- struct void *curlm;
++ void *curlm;
+ #endif
+ } perl_curl_multi;
+
diff --git a/gnu/packages/patches/perl-www-curl-remove-symbol.patch b/gnu/packages/patches/perl-www-curl-remove-symbol.patch
index ae3486708b..c32a34897b 100644
--- a/gnu/packages/patches/perl-www-curl-remove-symbol.patch
+++ b/gnu/packages/patches/perl-www-curl-remove-symbol.patch
Binary files differ
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0bfaa3b9d7..8947889cd7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4423,14 +4423,14 @@ RFC 6570.")
(uri (string-append
"mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
version".tar.gz"))
- (patches (search-patches "perl-www-curl-remove-symbol.patch"))
+ (patches (search-patches "perl-www-curl-fix-struct-void.patch"
+ "perl-www-curl-remove-symbol.patch"))
(sha256
(base32
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
(build-system perl-build-system)
(arguments
'(#:tests? #f ;XXX: tests require network access
-
#:phases (modify-phases %standard-phases
(add-before 'configure 'set-search-path
(lambda _