summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-01-27 17:17:08 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-27 21:18:22 +0100
commit2c24aa2720a06f4fd85b41e1f507367708e7efc3 (patch)
tree92484598443582fd237315a53b219245c853380e
parent046474c5a8db3398f071a617e2701010ea6e9aa5 (diff)
downloadguix-patches-2c24aa2720a06f4fd85b41e1f507367708e7efc3.tar
guix-patches-2c24aa2720a06f4fd85b41e1f507367708e7efc3.tar.gz
gnu: Add emacs-templatel.
* gnu/packages/emacs-xyz.scm (emacs-templatel): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2848dc6159..48a0b2a517 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9366,6 +9366,28 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(home-page "http://web-mode.org/")
(license license:gpl3+)))
+(define-public emacs-templatel
+ (package
+ (name "emacs-templatel")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clarete/templatel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1k33h503038l2bcr8gs020z2cjxfs94lamkdgv52cvd9i20d0kqq"))))
+ (build-system emacs-build-system)
+ (home-page "https://clarete.li/templatel")
+ (synopsis "Jinja inspired template language for Emacs Lisp")
+ (description
+ "templatel is the modern templating language. It provides variable
+substitution and control flow through a clean and powerful language inspired
+by Python's Jinja.")
+ (license license:gpl3+)))
+
(define-public emacs-wgrep
(package
(name "emacs-wgrep")