summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-03 20:33:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-05 07:03:11 +0200
commit2b504cc3d1977eacc28ed8a706d6f6606f01d801 (patch)
tree02b048964db41363d039ba5f64101590f3020f0c
parent8dca40a3def355725c1d612d4d0caa3e5db72964 (diff)
downloadguix-patches-2b504cc3d1977eacc28ed8a706d6f6606f01d801.tar
guix-patches-2b504cc3d1977eacc28ed8a706d6f6606f01d801.tar.gz
gnu: mosh: Remove ‘/bin/sh’ dependency.
* gnu/packages/ssh.scm (mosh)[arguments]: Add ‘patch-FHS-file-names’ phase.
-rw-r--r--gnu/packages/ssh.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index ea42e72de2..38b98f1c5b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -405,6 +405,12 @@ authentication scheme.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-FHS-file-names
+ (lambda _
+ (substitute* "scripts/mosh.pl"
+ (("/bin/sh")
+ (which "sh")))
+ #t))
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'mosh' can find 'mosh-client' and