summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-07 13:48:45 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-08 14:55:49 +0200
commit28ae35850357acfda42d3c82c29df37149a6b8d0 (patch)
treec7b6494ebc5dc51e6724d8c91e11ea2a79729211
parente118348a1d4ee99e13a0d3ac2f952122c438923e (diff)
downloadguix-patches-28ae35850357acfda42d3c82c29df37149a6b8d0.tar
guix-patches-28ae35850357acfda42d3c82c29df37149a6b8d0.tar.gz
gnu: ocaml: Depend on libiberty.
Currently gcc:lib does not include libiberty so this change restores the initial intent. * gnu/packages/ocaml.scm (ocaml-4.11)[inputs]: Replace "gcc:lib" by "libiberty".
-rw-r--r--gnu/packages/ocaml.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 427ea38ccc..272f5bf268 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -200,8 +200,7 @@ This package produces a native @command{ocamlc} and a bytecode @command{ocamllex
("pkg-config" ,pkg-config)))
(inputs
`(("libx11" ,libx11)
- ;; For libiberty, needed for objdump support.
- ("gcc:lib" ,(canonical-package gcc) "lib")
+ ("libiberty" ,libiberty) ;needed for objdump support
("zlib" ,zlib))) ;also needed for objdump support
(arguments
`(#:phases