summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-06 12:02:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-06 12:02:09 +0300
commit25a23a8d4a92150503f7ef8ea577ab7524531247 (patch)
treecddbc4da556c093cb399e6354d3a6d7ca7052f16
parent4c93818392fcfce9238816c232b6d58cc64ecd8a (diff)
downloadguix-patches-25a23a8d4a92150503f7ef8ea577ab7524531247.tar
guix-patches-25a23a8d4a92150503f7ef8ea577ab7524531247.tar.gz
gnu: Add python-patiencediff.
* gnu/packages/python-xyz.scm (python-patiencediff): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6d6b60db83..55860fa57f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4481,6 +4481,26 @@ library, libgit2 implements Git plumbing.")
;; GPL2.0 only, with linking exception.
(license license:gpl2)))
+(define-public python-patiencediff
+ (package
+ (name "python-patiencediff")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "patiencediff" version))
+ (sha256
+ (base32
+ "0yjk50lsd4gnllxls925xbcdxwvmda37w2a1shk0p1nvl3fcha6q"))))
+ (build-system python-build-system)
+ (home-page "https://www.breezy-vcs.org/")
+ (synopsis "Python implementation of the patiencediff algorithm")
+ (description
+ "This package contains a Python implementation of the @code{patiencediff}
+algorithm. Patiencediff provides a good balance of performance, nice output for
+humans, and implementation simplicity.")
+ (license license:gpl2)))
+
(define-public python-pyparsing
(package
(name "python-pyparsing")